Skip to Content
author's profile photo Former Member
Former Member

SAP Fiori CRUD Master-Detail Application template issues on SAP Web IDE

Hello Experts,

I am facing certain issues with the new Fiori Master-Detail CRUD app template, on SAP Web IDE.

I tired using the CRUD app template for both SAPES1 OData service URL - " https://sapes1.sapdevcenter.com/sap/opu/odata/sap/ZGWSAMPLE_SRV/ " as well as Northwind OData service URL - " http://services.odata.org/V2/(S(1kmuijkrksjfeu3nw4014hna))/OData/OData.svc/Products " .

Kindly note:- Both SAPES1 and Northwind destinations have been properly added in my SAP HANA Cloud Trial account. When I run the " test.html" file and choose " test/flpSandbox.html" I am encountering error messages.

For the SAPES1 service, I am encountering " CSRF token validation failed" message and the UI is completely blank.

I also created another CRUD app with Northwind OData service, the one with Read/Write capabilities and by specifying "v2" in the OData service URL for version 2,.

In this app, I initially get a error prompt which reads " Query options $orderby, $inlinecount, $skip and $top cannot be applied to the requested resource".

However, upon closing the error prompt, my app UI shows data from backend. When I click on the " + " , the Create New Entity screen is displayed, in which I am able to enter details and save it on to the backend.

Upon saving, I again encounter the same error prompt "Query options $orderby, $inlinecount, $skip and $top cannot be applied to the requested resource".

And the Entity I have created is visible , but only until I refresh the page.

Once I refresh or when I open the app after few hours, the new entity is no more available in the Master list.

Could you kindly tell me what needs to be done to get the Fiori Master-Detail CRUD app working, in order to update the records on back-end.


Thank you, Suraj Kumar Y. Midgay

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Feb 15, 2016 at 07:11 PM

    For the CSRF issue there is a solution here:

    http://scn.sap.com/message/16527913#16527913

    Could you please try and see if it helps you?

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Offer,

      Thanks for sharing the link for CSRF issue.

      I have tried the code snippet from the link and it has resolved my CSRF issue.

      For the Northwind issue, I will check by using the URL you have mentioned.

      Thanks for the inputs, will let you know.

      Thanks,

      Suraj Kumar.

  • Posted on Feb 14, 2016 at 07:14 AM

    Hi,

    Please let's separate the issues:

    1. CSRF token issue seems like a configuration issue because we are using the UI5 Odata model which handles CSRF seamlessly.

    Could you please share your destination configuration?

    2. Northwind issue - I took the specified service: http://services.odata.org/V2/(S(1kmuijkrksjfeu3nw4014hna))/OData/OData.svc/Products " .

    and it is different from the original Northwind.

    Could you please describe how did you create this one and what is its backend system?

    Regards,

    Offer.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Offer,

      I am currently using the Version 2 of the Northwind OData service. The URL for which is as following.

      " http://services.odata.org/V2/(S(hquzgekfnzc5gxu11e1gyzef))/OData/OData.svc/ "

      However, I am facing the same OData service error prompt as stated below.

      " Query options $orderby, $inlinecount, $skip and $top cannot be applied to the requested resource ".

      Below screenshots are of the Northwin DEstination in HCP and frm CRUD app template.

      1) Northwind OData Service Destination in HCP

      2) Specifying the Northwind URL in CRUD app template

      3) Selecting Entity in Template Custumization

      4) OData error prompt while executing / testing the app

      I get the above error prompt when the app initially loads, as well as whenever I add a new entity on the Create New Entity " + " button and click the " Save " button.

      Could you kindly let me know, what am I missing to get the app running without any error prompts?

      Looking forward for your valuable suggestions and insights.

      Thanks,

      Suraj Kumar

  • Posted on May 01, 2016 at 06:28 PM

    Hi Suraj,

    I have a similar requirement and I am not able to create an entry and save it. It shows "Sorry, a technical error occurred! Please try again later".

    And I am facing the same problem you faced while editing new entries.

    Hope you help me resolve it. Experts in the forum also please provide your suggestions for the same.

    Thanks,

    Srinivasan

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.