Skip to Content
0
Feb 03, 2016 at 03:45 PM

Connect with ADO.NET 4.5 to SAP HANA

347 Views

Hello,

I want to share a finding that I made when I tried to connect with a C# ADO .NET 4.5 program to Hana. I am sorry, if this already has been posted earlier, but I did not find this when I searched for it.

1. You need to install the 32 and 64 bit version of the HDB client because of Visual Studio. If you only install the 64 bit version you will get a "cannot find libSQLDBCHDN.dll" message, when you try to run your program, as it is looking for the 32 bit version of the libSQLDBCHDN.dll

2. Both HDB clients must be from the same revision otherwise you will "version mismatch" error, when running the program.

Best regards

Ercin Nurol