Skip to Content
0
Jan 29, 2016 at 03:11 PM

WebDispatcher : SRCURL to redirect only specific Webdynpros

230 Views

Hello,

We are running HR Renewal 2.0 and as such we had to setup the Webdispathcer rules as indicated in the Administrator Guide.

Basically the same URL is used to access services in the two backends systems ECQ and GWQ

wdisp/system_1 = SID=GWQ, MSHOST=srv-qsap-gwpa.domain, MSPORT=8111, SRCSRV=*:44310, SRCURL=/sap/saml2/sp/;/sap/opu/sdata/;/sap/opu/odata/;/sap/bc/ui2;/sap/public/bc/ui2/;/sap/bc/ui5_ui5/sap/arsrvc_suite_pb/,CLIENT=400

wdisp/system_2 = SID=ECQ, MSHOST=srv-qsap-ecpa.domain, MSPORT=8111, SRCSRV=*:44310, SRCURL=/,CLIENT=400

No problem until that. (Note that all the HR webdynpros are found in the ECQ system)

Now we are also using an Identity Provider (ADFS) and the following Webdynpro needs to be found on the GWQ System:/sap/bc/webdynpro/sap/saml2

So I tried all the following settings and it did not work :

wdisp/system_1 = SID=GWQ, MSHOST=srv-qsap-gwpa.domain, MSPORT=8111, SRCSRV=*:44310, SRCURL=/sap/bc/webdynpro/sap/saml2;/sap/saml2/sp/;/sap/opu/sdata/;/sap/opu/odata/;/sap/bc/ui2;/sap/public/bc/ui2/;/sap/bc/ui5_ui5/sap/arsrvc_suite_pb/,CLIENT=400

wdisp/system_1 = SID=GWQ, MSHOST=srv-qsap-gwpa.domain, MSPORT=8111, SRCSRV=*:44310, SRCURL=/sap/bc/webdynpro/sap/saml2*;/sap/saml2/sp/;/sap/opu/sdata/;/sap/opu/odata/;/sap/bc/ui2;/sap/public/bc/ui2/;/sap/bc/ui5_ui5/sap/arsrvc_suite_pb/,CLIENT=400

wdisp/system_1 = SID=GWQ, MSHOST=srv-qsap-gwpa.domain, MSPORT=8111, SRCSRV=*:44310, SRCURL=/sap/bc/webdynpro/sap/saml2/;/sap/saml2/sp/;/sap/opu/sdata/;/sap/opu/odata/;/sap/bc/ui2;/sap/public/bc/ui2/;/sap/bc/ui5_ui5/sap/arsrvc_suite_pb/,CLIENT=400


I read the documentation again, and it turns out that SRCURL specifes the possible URL prefixes, so if I add the prefix /sap/bc/webdynpro/sap/ to

GWQ, il would work fine, but then all HR Webdynpros would not be found on ECQ



wdisp/system - SAP Web Dispatcher - SAP Library



saml2 is not a prefix, it is a webdynpro.

Is there a way to exclude the Webdynpro saml2 from being found on ECQ ?

Is there a way to selectively force the sapwebdispatcher to look for /sap/bc/webdynpro/sap/saml2 on GWQ ?



Thank you






Attachments

rabhi3.png (20.4 kB)