Skip to Content
Former Member
Jan 28, 2016 at 06:23 PM

Synchronous Webservice & XML gateway application / Firewall config


Hello!! Gurus

We have been diligently working on building synchronous web services interface with the below pattern.

Internal Application(sync web services) ---> SAP PI ----> External Vendor (sync web services)

Thanks for the earlier responses on build & config. activity!!!

We are currently at a point where are looking to send message to the external vendor & get response back - however, we have a gateway appche application server & firewall which we have to take in to consideration.

In the past we had inbound asynchronous interface so we had written some rules where the sender comm. channel was specified as below in the gaeway Appache appl. server

Example: /ws/XISOAPAdapter/MessageServlet?channel=:BC_ExternalVendor:CC_ExternalVendor_SOAPSender

SO THAT any incoming Inbound Async can routed to the correct Sender Channel URL

HOWEVER, now that we have synchronous web-services - and there is no sender channel for inbound response coming back as it is triggered by the BC_InternalApplocation:CC_InternalApplocation_SOAPSender

In case of the starlight forward Async outbound - we had ONLY specified the proxy serer host name in the channel.

We are currently getting this error (however, there is some firewall or gateway application config. setting that we need to request with infrastructure team).

<SAP:AdditionalText> Connection closed by remote host.</SAP:AdditionalText>

To Summarize:

  • For Synchronous outbound interfaces to external vendors - wat typically needs to be taken care off in the firewall seeting - any specific port of IP needs to be included ?!
  • If we have an gateway application server - apart from configuration this as the proxy server - wat URLs similar to the one above needs to configured so the response is coming (unlike wat we had configured earlier for async inbound)

Hope my message is clear - please email me if you need any addl. details or if I am unclear (apologies for the lengthy message)

Your help is greatly appreciated!!

Thank you,