Skip to Content
0

Weird table links

Feb 06, 2017 at 10:09 AM

33

avatar image

I have data that I am trying to pull from multiple tables, except the links are not sane. The basic data is in a Material_Transaction table, this has all of the data I need, but in order to link it back to a job it works like this. If I want shipments to outside vendors I connect the table to the job table using the job field which is an easy attachment. If I want to see what what returned form those same vendors, I have to link it back through the source table since the job field is blank using the source field in both the job table and the material transaction tables. Is there any way I can hook these up so that they work without making two different reports. The goal is to add a single report to another report as a sub report.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Ian Waterman Feb 06, 2017 at 10:34 AM
0

Looks like you have to add the Material_Transaction in again and link from job table to relevant field.

Crystal will complain that you are adding in table again just ignore. Crystal will create an Alias name as Material_Transaction_1. You can change this to something more meaningful such as Material_Transaction_source.

Ian

Show 1 Share
10 |10000 characters needed characters left characters exceeded

I have already tried that and do not get all of the data. I will get everything that has gone and come back, but nothing that has gone and not come back.

0