Skip to Content

MDG-C Update of one custom entity is not working

Hi,

I am having one issue in MDG-C. I have created one new custom entity in company code. For that I have created the handler class and Genil model class. The new records are getting created and distributed correctly in MDG & ECC. When I am updating the existing record, its not working.

Could you please help me where to dig.

I also have one question. How I debug the handler class after final submission of my request as its not possible. I put in all methods but unfortunately the break points are not getting trigerred.

Any clue is welcome.


Thanks in advance.

Regards,

Pranab

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Posted on Feb 01, 2016 at 01:19 PM

    Hi Guys,

    I need your help on the above post. I can debug now and what i found is that when I am updating my custom entity the data are getting reflected in the UI and MAP_DATA_2STA method contained the chnage data but after final processing I have observed that MAP_BP_Z_ALTPAY_2API method doesnt contain the delta changes.

    Is there any Genil related issue/switch related.

    I badly need your help guys.

    Many Thanks,

    Pranab

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.