Skip to Content
avatar image
Former Member

How to change ABAP message server port for sapmsSID

Hello friends,

Can you please help me to understand how can we change ABAP message server port ?

Our scenario :

We had installed ASCS with instance number 02, which made message server port as 3602.

Now, as per requirement of client, we need to have ASCS instance number as 00 with abap message server as 3600.

So, I used SWPM and used System Rename option to change Instance number of ASCS to 00 from 02. But still message server port in use is 3602 as visible in dev_ms OR transaction SMMS.

Then, I decided to uninstall ASCS which I had created after rename.

After this I installed ASCS again with instance number 00. In Installation screen, it asked me message server port which I used 3600 (somehow it was prompting for again 3602).

Even, after installation of ASCS with instance number 00, message server port is 3602. System is running normally, means I can start it and login.

* /etc/services has correct entry.. sapmsSID pointing to 3600/tcp.

So, question is how can change abap message server for sammsSID to listen to port 3600.

Regards,

Ashish

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jan 16, 2016 at 06:48 PM

    Hi Ashish,

    Is there any existing instance running on server with instance no: 00 ?

    If yes, then installation can't move ahead by selecting instance 00 for ASCS. You can go ahead by selecting any other instance no. Once the instance installation get complete, you can modifiy the sapms<SID> in services file to 3600, so you ASCS message service can run with 3600.

    But we have to make sure there is no other instance running with port 3600.

    Regards,

    Anil

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 16, 2016 at 07:26 PM

    Hi Vikas.

    Is it dual stack system?  I think best way to perform the SAP System copy(Homogeneous method) to change the message server. 

    Regards

    SS

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 18, 2016 at 08:27 PM

    Hello Ashish,

    * /etc/services has correct entry.. sapmsSID pointing to 3600/tcp.

    This would be where the Message Server would take the port number, by default.

    You can confirm that the parameter "rdisp/msserv" is set correctly.

    Usually, this should be set at the DEFAULT.PFL only.

    But you can verify the ASCS instance profile as well, as it would overwrite the settings at the DEFAULT.PFL.

    Regards,

    Isaías

    Add comment
    10|10000 characters needed characters exceeded