Skip to Content

Cannot get HCI to connect between ERP and HCI

Hello,

I was hoping someone might have seen this error message from HCI before. I am attempting to perform basic setup of ECC to C4C via HCI. I am following the Integrating SAP Cloud for Customer with SAP ERP using SAP HANA Cloud Integration https://websmp105.sap-ag.de/~sapidb/012002523100011923832015E/1508_Config_ERP_HCI_COD.pdf

I have configured the ERP and iFlows in the HCI system INCLUDING installing SSL certs in STRUST as per instructions. However, I continue to receive the following message:

[CAMEL][IFLOW][ERROR] : Integration flow failed.

[CAMEL][IFLOW][EXCEPTION] : java.util.concurrent.TimeoutException

[CAMEL][IFLOW][UNRESOLVED] : Unresolved dependency: (&(keystore=default)(objectClass=com.sap.esb.security.KeyCertificateAccessor))

[CAMEL][IFLOW][UNRESOLVED] : Unresolved dependency: (objectClass=com.sap.esb.security.TrustManagerFactory)

[CAMEL][IFLOW][UNRESOLVED] : Unresolved dependency: (objectClass=com.sap.esb.security.KeyManagerFactory)

Has anyone seen this error before?

Thanks in advance for your replies!

Regards,

Steve

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jan 14, 2016 at 04:20 AM

    Hello Steve,

    Did you install the required certificates?

    Add a comment
    10|10000 characters needed characters exceeded

    • HI Raghuraman,

      Thank you for taking the time to reply. Yes, All SSL certificates have been installed on the ERP side. Additionally if I open the browser and perform a basic "PING" via HTTPS on the port for SSL connections I get a good response.

      Thanks,

      Steve

  • Posted on Jan 14, 2016 at 10:45 AM

    Hello Steve,

    Please find the below details it might be helpful,

    1. For connections initiated by the SAP ERP system to SAP HCI, you need to add the root certificate from SAP HCI in the Trust Manager (STRUST) transaction in your ERP system.
    2. For connections initiated by SAP HCI to the SAP ERP system, the root certificate from your SAP ERP system needs to be added in the keystore in your SAP HCI tenant.This should have been taken care of during the initial setup phase by the Cloud Operations team.
    3. Make sure that the SAP HCI user that is used to trigger calls from outside the middleware to SAP HCI has the necessary permission for sending messages.

    Also please check if you have selected Basic Authentication for Sender System [ You will be able to set it by navigating to Properties window post selecting Sender System ]

    Regards,

    Sriprasad Shivaram Bhat

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Sriprasad,

      Thanks for taking the time to reply. My answers to your queries are as follows:

      1. Yes, all entries per installation instructions are in STRUST in the ERP.

      2. This may be a NO? Since I am new to the HCI system, this may not be done? IF this is an SAP responsibility is it my job to confirm this? Can you please give me the menu path or screen shot of where to look for this? We did receive our provisioning email, but if this is an SAP task, shouldn't this already be done? Can you please post a screen shot where I can confirm this?

      3. The user that triggers this is an SAP R/3 ECC System, so the output is an IDOC. The installation instructions specify that an ABAP report RCOD_CREATE_CONNECTIVITY_SIMPL be used. This report walks thru the steps that are needed for download of customer data into HCI. A screen shot of this is here:

      Then the final step is to just generate the setup which has been done successfully..

      Thanks,

      Steve

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.