Skip to Content

NavigationSettings and NavigationParameters not resolved in SAP Portal 7.4

Hi Experts,

In my SAP Portal 7.4, the Portal Application (migrated from 7.0) is unable to traverse to portal link.

I followed the below reference.

Creating an OBN Link (Portal Runtime) - Portal - SAP Library

But got error for 2 classes com.sapportals.portal.navigation.NavigationSettings & com.sapportals.portal.navigation.NavigationParameters that they cannot be resolved...

while for the below code especially on navGenerator.createAbsoluteNavigateClientCall(launchUrl,navParams,navSettings);

com.sapportals.portal.navigation.NavigationSettings navSettings = new NavigationSettings(); com.sapportals.portal.navigation.NavigationParameters navParams = new NavigationParameters(); navSettings.setMode(INavigationConstants.SHOW_INPLACE);

linkString = navGenerator.createAbsoluteNavigateClientCall(launchUrl , navParams, navSettings);

My DC is already referencing to tc/ep/navigation/api.

Can anybody help on this.

Regards,

Lakshmikanthaiah

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Jan 14, 2016 at 09:39 AM

    Hi Friends,

    I have resolved the my self with below code.

    launchUrl="< PCD path of the iView >";

    IPortalComponentURI compURI=request.createPortalComponentURI();

    compURI.setContextName(launchUrl);

    linkString ="EPCM.doNavigate('" + compURI.toString() + "',2,'width=1000, height=800','my_window');";

    linkString will be incorporated with onClik of HTML link as below.

    sb = new StringBuffer();

    sb.append( "<a class=\"urLnk\" onClick=\"" );

    sb.append( linkImage.getLink() );

    sb.append( "\">" );

    sb.append( title );

    sb.append( "</a>");

    And it worked, thanks.

    Regards,

    Lakshmikantha

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 12, 2016 at 06:19 AM

    Hi Lakshmikanthaiah,

    Can you please paste the references maintained in your portal descriptor (portalapp.xml)

    Please ensure that you have followed the following document: How To... Migrate Custom Portal Applications to SAP NetWeaver 7.3

    Best Regards,

    Rohit

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.