Skip to Content

Hana sp11 installation and upgrade on linux RH

I have tried to install HANA sp11 as fresh install and also tried to upgrade my existing sp10 database. Both upgrade and new installation failing.

New installation failure:

nstalling package 'EPM'...

Installing package 'Documentation'...

Installing package 'Delivery Units'...

Installing package 'DAT Languages'...

Installing package 'DAT Configfiles'...

Creating instance...

  hdbparam: Working configuration directory:  "/vicky1/hana11/SB4/global/hdb/custom/config"

  hdbnsutil: creating persistence ...

  hdbnsutil: writing initial topology...

  hdbnsutil: writing initial license: status check = 2

Installation failed

  unhandled exception: Can't load '/vicky1/download/sp11/SAP_HANA_DATABASE/instruntime/SSLeay.so' for module Net::SSLeay: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory at DynaLoader.pm line 193.

at sdbrun/Require.pl line 62.

BEGIN failed--compilation aborted at IO/Socket/SSL.pm line 19.

Can't locate Net/SSL.pm in /vicky1/download/sp11/SAP_HANA_DATABASE/instruntime/SDBINST.TGZ /vicky1/download/sp11/SAP_HANA_DATABASE/instruntime (/vicky1/download/sp11/SAP_HANA_DATABASE/instruntime/SDBINST.TGZ /vicky1/download/sp11/SAP_HANA_DATABASE/instruntime contains: /vicky1/download/sp11/SAP_HANA_DATABASE/instruntime/SDBINST.TGZ, /vicky1/download/sp11/SAP_HANA_DATABASE/instruntime) at Net/HTTPS.pm line 30

    0: SDB::Install::App::__ANON__ in source SDB/Install/System.pm line 4012

    1: SDB::Install::System::loadSSLRequiringPackage in source SDB/Install/SAPControl.pm line 207

    2: SDB::Install::SAPControl::init in source SDB/Install/SAPControl.pm line 76

    3: SDB::Install::SAPControl::new in source SDB/Install/SAPInstance/TrexInstance.pm line 4252

    4: SDB::Install::SAPInstance::TrexInstance::cleanupLocalLeftovers in source SDB/Install/SAPInstance/TrexInstance.pm line 4456

    5: SDB::Install::SAPInstance::TrexInstance::startLocalSapStartSrvUx in source SDB/Install/SAPSystem.pm line 1500

    6: SDB::Install::SAPSystem::createInstance in source SDB/Install/App/Installation.pm line 848

    7: SDB::Install::App::Installation::install in source SDB/Install/App/Console/Installation.pm line 623

    8: (eval) in source SDB/Install/App/Console/Installation.pm line 611

    9: SDB::Install::App::Console::Installation::main in source SDBRun.pl line 396

    10: (eval) in source SDBRun.pl line 395

    11: SAPDB::Install::Start::StartRequireInc in source SDBRun.pl line 263

    12: SAPDB::Install::Start::Start in source -e line 0

Log file written to '/var/tmp/hdb_SB4_install_2016-01-08_13.56.06/hdbinst.log' on host 'JYOL00547447A'.

[root@JYOL00547447A SAP_HANA_DATABASE]#

and upgrade failure:

Select a SAP HANA Database installation:

No | System | Properties

------------------------------------------------------------

   |        |

0  | SB3    | version: 1.00.100.00.1434512907

   |        | host: jyol00547447a (Database Worker (worker))

   |        |

1  | None   | (Abort upgrade)

Specify the sequence number of the system to be upgraded [1]: 0

Enter System Administrator (sb3adm) Password:

Enter Database User Name [SYSTEM]:

Enter Database User (SYSTEM) Password:

Summary before execution:

   SAP HANA System ID: SB3

   Database User Name: SYSTEM

Do you want to continue? (y/n): y

Checking upgrade...

Upgrade failed

  unhandled exception: Cannot load libssl.so.0.9.8

For more information, see SAP Note 2009879.

    0: SDB::Install::App::__ANON__ in source SDB/Install/SAPControl.pm line 208

    1: SDB::Install::SAPControl::init in source SDB/Install/SAPControl.pm line 76

    2: SDB::Install::SAPControl::new in source SDB/Install/SAPInstance/TrexInstance.pm line 4173

    3: SDB::Install::SAPInstance::TrexInstance::checkSapStartSrv in source SDB/Install/SAPSystem.pm line 3518

    4: SDB::Install::SAPSystem::checkUpdate in source SDB/Install/App/Console/DBUpgrade.pm line 421

    5: SDB::Install::App::Console::DBUpgrade::preinstall in source SDB/Install/App/Console/DBUpgrade.pm line 566

    6: (eval) in source SDB/Install/App/Console/DBUpgrade.pm line 556

    7: SDB::Install::App::Console::DBUpgrade::main in source SDBRun.pl line 396

    8: (eval) in source SDBRun.pl line 395

    9: SAPDB::Install::Start::StartRequireInc in source SDBRun.pl line 263

    10: SAPDB::Install::Start::Start in source -e line 0

[root@JYOL00547447A SAP_HANA_DATABASE]#

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 11, 2016 at 10:05 AM

    Hi Saroji,

    Please check the below SAP note.

    8:31:54.105 - ERR : Can't load '/root/51049932/DATA_UNITS/HDB_LCM_LINUX_X86_64/instruntime/SSLeay.so'

    for module Net::SSLeay: libssl.so.0.9.8: cannot open shared object file: No such file or directory at DynaLoader.pm line 193.

    Solution:

    For running SAP HANA you may need libopenssl version 0.9.8.
    This version of libopenssl is provided with the so called Legacy Module for x86_64.
    This software repository can be added via YaST2.

    1. Select in YaST2 Software->Add-On-Products.
    2. Select Add.
    3. Choose Extensions and Modules from Registration Server ....
    4. Select the Legacy Module for x86_64.
    5. The repository is added to your system.
    6. Now you can install the libopenssl 0.9.8 via zypper, yast2 etc.  E.g. zypper in libopenssl_0_9_8.

    2240961 - Deployment of SAP Host Agent configurations fails when upgrading HANA database

    Regards,

    Govind

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 10, 2016 at 05:52 PM

    This is because there are some missing libraries in your system.

    1) Install required libraries as per the document attached to the SAP Note: 2009879

    2) Follow some extra configuration steps as in SAP Note: 2136965

    Please close this thread if this answers your question. thanks

    Saddy Bhat

    Add comment
    10|10000 characters needed characters exceeded