Skip to Content

Problem with UMT (Upgrade Management Tool)

Hello there !

We have 2 machines on Windows Server 2012 R2, and installed on both BI4.1 SP7.

On the test machine all works and on the pre-production machine, we have a java problem with the UMT, whne we execute it, we have this error :

We tried many solutions without success, and both machines have the same Java version (7.80 64bits), same OS, etc...

We tried to copy the "upgrademanagementtool.jar" from the test machine to the other one, we execute on a CMD windows :

java.exe -jar "D:\businessobjects\SAP BusinessObjects Enterprise XI 4.0\java\apps\upgradeManagementTool\jars\upgrademanagementtool.jar"

Exception in thread "main" java.lang.NoClassDefFoundError: org/osgi/framework/BundleException

Caused by: java.lang.ClassNotFoundException: org.osgi.framework.BundleException

at java.net.URLClassLoader$1.run(URLClassLoader.java:255)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:243)

at java.lang.ClassLoader.loadClass(ClassLoader.java:372)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:344)

at java.lang.ClassLoader.loadClass(ClassLoader.java:313)

Could not find the main class: com/businessobjects/upgrademanager/bootstrap/Main. Program will exit.

Someone had already this problem maybe ?

Thank you

umt error.jpg (18.2 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 08, 2016 at 09:47 AM

    Hello Wendy,

    You can use Process Monitor to trace all files used by UMT.

    The output will show the files loaded successfully during run time, but also the files that were not found, there might be more then just "upgrademanagementtool.jar" missing.

    Once the missing files are identified, you can add them manually from a different machine were UMT is running correctly.

    1842413 - How to use Process Monitor?

    I hope this helps,
    Moslem

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jan 13, 2016 at 08:44 PM

    Hi Wendy ,

    Please perform below steps to resolve the issue :

    • There was incorrect path mentioned in upgradeManagementToolSystem.properties in location /usr/sap/bi4/sap_bobj/enterprise_xi40/java/apps/upgradeManagementTool/jars.
    • For e.g:- The tag in upgradeManagementToolSystem.properties "//sap_bobj/enterprise_xi40/java/lib/".
    • After correcting the paths in upgradeManagementToolSystem.properties, again run the same command

    Please let me know if you have any more queries.

    regards,

    Mahak

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.