Skip to Content
avatar image
Former Member

BIPST - Unable to validate the JMX Configuration

Hello Experts,

The SAP BI Platform Support Tool seems an awesome and much needed tool. My thanks to the development team who put great efforts in putting this together.

Ok, now coming to my issue...

We have BOE 4.1 Services on a Physical Machine and the default Tomcat 7 on a virtual machine with Windows Server 2012 R2 on both the servers. We have firewalls in our network and disabling them is not an option for us (sad)

So I have been successful installing the SAP BI Platform Support Tool, and configuring the SAP Host Agent on both BOE Server and Tomcat Server. However, I'm unable to make JMX work on the Tomcat server. On the Tomcat server, I have the following parameters added to the TOMCAT --> Java --> Java Options

-Dcom.sun.management.jmxremote
-Dcom.sun.management.jmxremote.port=8008
-Dcom.sun.management.jmxremote.authenticate=false
-Dcom.sun.management.jmxremote.ssl=false
-Djava.rmi.server.hostname=TomcatHostName

I copied the 'operations.d' file from BIPlatformSupportTool installation folder to the SAP folder on both the BOE server and Tomcat Server as mentioned in the guide.

Now on the SAP BIPlatformSupport Tool, I have configured the BOE server node and the Tomcat web app. The BOE Server node is working fine. On the Tomcat web app node, I'm able to validate the 'HostAgentSettings' which is connecting to TomcatHost on port 1128. And on the JMX Settings, I have 8008 as the JMX port and this port is opened on the Tomcat server. But when I try to validate the JMX Configuration, I get an failure message 'JMX Configuration validation failed for this node. Check Port and authentication options and try again'. On checking the firewall logs on the Tomcat Server, I could see connection requests from the SAPBIPlatformSupportTool client machine getting dropped and the ports it is trying to connect seems random.

From the BIPST client, I'm able to 'telnet tomcatserver 8008' (without single quote) and it is returning blank screen. On the BIPST client machine, I have the tomcathostname and IP address added to the HOSTS file (located in the C:\Windows\System32\drivers\etc folder)

I have gone through the instructions and guide multiple times and I'm unable to understand what I'm missing. Is there any other port (apart from 1128, 8008, 8080, and all other BO required ports) that needs to be opened to validate this JMX configuration?

I appreciate your help.

Thanks,

ilyas

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 09, 2016 at 03:33 PM

    Hi Ilyas,

    Ok, so it turns out that you need a special configuration to use JMX connection through a firewall which is to use a RemoteJMXLifecycleListener. The communication problem is similar to CORBA where there is actually two ports that need to be opened on the firewall.

    This configuration is documented here:

    https://tomcat.apache.org/tomcat-7.0-doc/config/listeners.html#JMX_Remote_Lifecycle_Listener_-_org.apache.catalina.mbean…

    I haven't tested this yet but will when I return to the office next week. Once tested, I'll update the BIPST documentation.


    Cheers

    Toby



    Add comment
    10|10000 characters needed characters exceeded

  • Jan 06, 2016 at 07:09 PM

    Hi Ilyas,

    OK, then I think I have some testing to do. You're not the first customer to run into this issue in regards to the firewall. Technically, TCP bi-direction communication on port 8008 should suffice but it's starting to look like something else is happening in the JMX handshake.

    I will test this scenario better and provide further guidance as soon as possible.

    Thanks for posting this issue!

    Regards

    Toby

    Add comment
    10|10000 characters needed characters exceeded