Skip to Content

MSSQL driver installation on SAP HANA One

Heyho and a happy new year!

I set up a SAP HANA One instance last year and updated it straight away to SPS10 as provided. Afterwards I tried to connect to a MSSQL database with Smart Data Access. According to the Administration Guideline I have to install unixODBC and the MSSQL driver.

But while trying to install the unixODBC driver I recevie a compiler error which says that the gcc compiler wasn't found in the PATH. I searched for the library on the SAP HANA One system but didn't find any valid library for installing unixODBC. Neverthelesse installing the gcc driver failed with several attempts (the entire library is to big for the small HANA One 64GB, etc.) Does anyone have any idea how I can setup unixODBC? I can't think that they removed the gcc compiler with SPS10 and in prior releases (SPS8/9) it is still available?

Regards,

Marcel

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jan 20, 2016 at 02:42 PM

    I found the solution or something like that (just in case someone looks into this discussion for a solution).

    unixODBC can't be installed due to the missing gcc compiler which isn't available on the SAP HANA One image. I don't know why despite the fact the installation is described in several YouTube videos.

    I added the ressources for oss and non-oss from SUSE for the SLES 11 SP3 version by

    sudo zypper ar http://download.opensuse.org/distribution/11.3/repo/oss/ oss

    sudo zypper ar http://download.opensuse.org/distribution/11.3/repo/non-oss/ non-oss 

    Afterwards you can install the gcc compiler by

    sudo zypper install gcc

    The installation process states that the installation can only be succeded by several options. Option (1) - the downgrade was the right choice. Afterwards it also pops up the follwing statement

    "The following packages are not supported by their vendor:

      cpp45 gcc gcc45 glibc glibc-devel glibc-locale libcloog0 libgcc45 libmpc2 libppl7 libppl_c2

      linux-glibc-devel openSUSE-release openSUSE-release-ftp"

    It seems that this kind of image isn't ready to use for unixODBC and therefore for MSSQL (Smart Data Access) but I don't know whether it was prupose by SAP or whatever.

    It was no problem to install the unicODBC driver as well as the MSSQL drivers after the installation of the gcc compiler.

    Regards,

    Marcel

    Add comment
    10|10000 characters needed characters exceeded