Skip to Content

SucessFactors Adaptor not using LastModifiedDate in web service query

Hi,

I have an issue with using the BODS 4.2 SuccessFactors Adapter to download data from PerformanceManager using lastmodifieddate as a delta.
When I restrict the data coming from PerformanceManager using the modified date, the web service query does not contain the date restriction in the where clause. All the data is brought back and then the date restriction is applied with the Data Services query transform. This gives a 3 step retrieval process i.e. web service query, transform restriction and load into target table.

However, if I restrict the data using a username, the web service query contains the restriction in the where clause. Thus, only data related to the username is retrieved from PerformanceManager. This gives a 2 step retrieval process i.e. web service query and then load into target table.

The only change between the scenarios above is the field I am using to restrict data within the DS query transform.

Has anybody else encountered this type of issue and can give advise as to how to resolve it?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Posted on Dec 28, 2015 at 11:15 AM

    I have no experience with this particular adapter, but note that pushing down SQL is a DS built-in feature. DS always tries to push down as much code as possible to the underlying database.

    In your particular case it might be that the constant specified in the where-clause is not of the correct (date) data type, then DS implicitly applies a conversion function for which it doesn't know the db equivalent and therefore decides not to push it.

    Check Let the database do the hard work! Better performance in SAP Data Services thanks to full SQL-Pushdown for examples from other environments and for solutions to this type of problem.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jan 13, 2016 at 05:11 PM

    Thank you for the reply. I tried the various techniques in your reply. Unfortunately none worked.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.