Skip to Content
0
Former Member
Dec 17, 2015 at 09:43 AM

CX_AI_SYSTEM_FAULT : SOAP:1.023 SRT: Processing error in Internet Communication Framework

1459 Views

Hello all,

I am trying to configure /solman_setup for SAP SOLUTION MANAGER 7.1

I am confused about this:

1. at system preparation > step 5.4 Set Authentification Policy for Agents > I am getting this:

Text(1) CX_AI_SYSTEM_FAULT : SOAP:1.023 SRT: Processing error in Internet Communication Framework: ("ICF Error when receiving the response: ICM_HTTP_SSL_ERROR") Text(2) Text(2) CX_SOAP_FAILURE : Error when processing Web service call Text(3) Text(3) CX_SOAP_CORE : Error when calling SOAP Runtime functions: SRT: Processing error in Internet Communication Framework: ("ICF Error when receiving the response: ICM_HTTP_SSL_ERROR")

I checked the certificates and all are self-signed, so I guess there is nothing to do here.

But when I click on Agent Administration ( also from the step 5.4)

Error Location SMDloggerSystem Text [J2EEClusterConnector.connect] Error occcured, accesspoint: p4:host:50004
[EXCEPTION]
com.sap.engine.services.jndi.persistent.exceptions.NamingException: Exception while trying to get InitialContext. [Root exception is com.sap.engine.services.jndi.persistent.exceptions.SecurityException: Cannot get InitialContext, operation is not allowed.]
at com.sap.engine.services.jndi.InitialContextFactoryImpl.getInitialContext(InitialContextFactoryImpl.java:455)
at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:667)

2. from Managed system configuration > step 3 Assigned Diagostic Agents >> SLD Agent Candidates tab >> click on get agents .. I am getting the same error

P:1.023 SRT: Processing error in Internet Communication Framework: ("ICF Error when receiving the response: ICM_HTTP_SSL_ERROR")

Error      Web service invocation problem on host and port 44300 protocol : https logical port name : LP_WS_SMDAGENT_MONITORING. Check note 1822831.

and No Diagnostics agents currently registered in SLD on host



Can you please suggest me something? I already tried everything I found on forums for this error.


Do you think the certificate error is related with the not connected agents?


Thank you

Chris