Skip to Content
0
Dec 16, 2015 at 07:12 AM

Installation of SAP on DB2 - Suse Linux 11

281 Views

Dear All, Installing SAP on DB2 , the db2installation getting error. It's trying to find libstdc++.so.5

************

cat /etc/issue

Welcome to SUSE Linux Enterprise Server 11 SP3 (x86_64) - Kernel \r (\l).

**********

<sapinst.log>

The required library file libstdc++.so.5 is not found on the system.

Check the following web site for the up-to-date system requirements

of IBM DB2 9.7

http://www.ibm.com/software/data/db2/udb/sysreqs.html

http://www.software.ibm.com/data/db2/linux/validate

Aborting the current installation ...

Run installation with the option "-f sysreq" parameter to force the installation.

ERROR 2015-12-16 11:44:29.831 (root/sapinst) [CInstallerCallBackImpl.cpp:259] id=ind-rel.ind-os.db6.j2ee-db.abortInstallation

Aborting the installation

********************************

Now, IBM Db2 says

http://www-01.ibm.com/support/docview.wss?uid=swg21423430

i.e I should install package compat-libstdc*

This package is only available for SUSE Linux 10 and Not for Suse linux 11.
This package is unsupported for Suse linux 11

Package list

SUSE Linux Enterprise Server 10 for x86 Package Descriptions

https://www.suse.com/LinuxPackages/packageRouter.jsp?product=server&version=11&architecture=i386&package_name=index_all

Please help to to go ahead with the error.
Should I install unsupported package of Suse linux 10 on Suse linux 11

Or should I go ahead with forced installation ( which I don't want to )
<Run installation with the option "-f sysreq" parameter to force the installation>

Thanks,

Regards,

Nick