Skip to Content

Supressing empty rows

I have several fields that can be null in a report that I am creating. If the field is null, I would like to not only suppress these fields from being displayed, but also prevent empty white space from showing up in the report.

Using the format editor for each field that I want to suppress, I've selected the Supress checkbox and added logic that checks whether the fields is null. That works in preventing these fields from being displayed (as well as other fields that "tie" to these fields), but it doesn't solve the problem of all the white space that's being displayed in the report.

Is there a way to prevent the white space from appearing in the detail section of a report ?

Thanks !

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Dec 16, 2015 at 04:42 AM

    Select Section expert and check Supress Blank Section

    Irfan


    crystal.jpg (78.9 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 16, 2015 at 05:01 AM

    Hi Lloyd,

    Are all these fields on the same details section?

    If no, they would first want to create multiple details section and move fields on their sections of their own (per line).

    You can then check the option Irfan suggests above for each details section.

    -Abhilash

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.