Skip to Content
avatar image
Former Member

SAP XI - how it works in your company ?

Good Morning together,

since 2005 we´re woriking with XI to map interfaces between SAP and non SAP Systems.

During our development we suffered on several problems which are "at present time" still existing in our development system. Production system is working fine.

Version:

SAP XI 3.0

Patch 15(newest stack) even with older patch levels (12 to 15)

System: Development and QA System on the same server !

Planed: Each system gets its own server !

Problems are:

- 1. Cache Problem "activated mappings/configuration" are not activated and not listed in the notification list.

Solution: "Start complete Cash refresh" ; Delta isn´t sufficient

- 2. Cache Problem activated mappings/configuration have no affect on sending new interfaces. Activation is listed as successful (included the notification list) but the results is with the old values(before activation).

Solution: "Start complete Cash refresh" ; Delta isn´t sufficient

- XI J2ee restart (many times a day)

sometimes after activation of objects(design/configuration)

- Mapping Resource (not found) Error in XML Monitor

Solution: Send interface again

- BPM Errors are not listed in the XML Monitor if the BPM failed after/during system problems/crash/restart(Column Technical Outbound Channel: PE). Only listed with the BPE Monitor "Diagnosis Processes with Errors"

Normal BPM Errors(Mapping error) are listed in the XML Monitor.

- often transport (CCMS) problems

- codepage problems with non SAP systems

- many other problems ... small but annoying

Many OSS calls refering to our problems have already been made. An SAP Consultant is still working with us on those issues.

Q:

Interesting to know "Do you have the same or similar problems with XI in your development systems" ?

Thanks for your opinion,

G. Breuer

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Feb 16, 2006 at 07:51 AM

    Hi Breuer,

    Yes, we also faced almost all of your problems.

    Still we couldn't solve

    >IR & ID connection break once in every 3-5 minutes.

    Interesting thing is that we have two DEV XI's and only one is having this problem.

    And the proposed solution is reinstallation.

    We spend more time on solving XI server problems than development.

    Regards

    Chemmanz

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      Michal really got the answer: Installation and Configuration is crucial. Your problems all lead to one or the other problems with configuration. I have seen similar problems at customers, where OSS messages as well as other consultants didn't fix things, however with a bit of effort we could stabilize those systems. What i have seen quite often is that JVM parameters are set through the install and never touched again, although these are crucial for the system to run stable. (e.g. frequent J2EE restart points to this...)

      Let me suggest you some steps what you could do now:

      - redo all post installation and configuration steps as listed in the guides thouroghly.

      - Go through the XI tuning guide especially the J2EE Engine part and focus on the memory configuration of the JVM. Get some background information on how JVM memory works and read through the according SAP Notes.

      - get a Going Live Check Session from SAP. Although you might have consultants right now, they are probably not Basis consultants, Support personnel in going live check sessions however do nothing else than working on system reviews and stabilization

      Regards

      Christine