Skip to Content
avatar image
Former Member

SAP EH&S Automatic Report Shipping

Hi Experts,

I have an issue while working on Automatic Report Shipping of SDS triggered by sales order.

I have made the required configurations for report shipping and the servers are up and running and the reports are in RELEASED status in CG50.

When I create sales order and save the same with O/P SDB i am getting error “No communication data has been defined for transmission medium 8”.

automatic-rs-1.jpgautomatic-rs-2.jpg

Also, I followed the solution suggested in the below link https://archive.sap.com/discussions/thread/3366429.

In SE38 I executed Program RSNAST00 and RC1SDAPL.

After executing the report RC1SDAPL below error message has been displayed with SRGV ID. I am not sure of this error.

Please help me out on this issue.

automatic-rs-1.jpg (263.3 kB)
automatic-rs-2.jpg (249.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Feb 04, 2017 at 04:19 PM

    Hello

    please execute always a search before placing questions. E.g.

    https://archive.sap.com/discussions/thread/3313369 (No communication data has been defined for transmission medium 8)

    PLease check as well: https://blogs.sap.com/2016/04/10/ehs-classic-report-distribution/

    PLease read very carefully the "report distribution" OSS note in which the set up is described

    Please close your parallel thread.

    In context of: "In SE38 I executed Program RSNAST00 and RC1SDAPL." => both reports should be handled as "jobs"; on quality SAP systems you can start them manually, but not in live system.

    The "debug" of report distribution logic is not easy. Looking on your "log" file: Currently no idea. The system seems to have a set up so that for a "specific" context the systems tries to find a released report of type "ANSI_CA" as generation variant. If this is correct or not: I can not decide

    The only topic which is obvious is the "strange" document type "(ZOK). If you have 100% used the best practise here. this is clearly wrong (should be SBR).

    C.B.

    PS: please check for combination of material number and specification key if you can find in CG50 a "report request". Then this would be ok and the reason that the logic stopped is "transparent" (partially).

    Add comment
    10|10000 characters needed characters exceeded

    • Dear Darshan

      for some meesage you have "green" status, Therefore you should ask yourself: what is the difference?

      In any case. this is a mismatch in "setuop" / "master data" before teh CVD! rpocxess starts. The "next" best might be to debug to get some ideas at whcih point the "error" is placed in log and than looking back to beginninung to detect the issue

      C.B.

  • Feb 04, 2017 at 04:28 PM

    Hello

    small add on: I can see two messages (related to same business partner etc.).. don't know the reason. I would expect that only one message should be placed. Can you check this as well.

    C.B.

    Add comment
    10|10000 characters needed characters exceeded