Skip to Content
author's profile photo Former Member
Former Member

SAP DVEBMGS00 resource relocation b/w RAC cluster nodes

Hi Gurus,

I have recently installed a Solution manager system (Solman 7.1) on Solaris 11.2 platform with Oracle 11.2.0.4 as database and DB is configured as 3 nodes RAC cluster. I have got 3 VIPs for ASCS, SCS and DVEBMGS00 instances.

I have successfully installed SAP system on RAC with 3 active DB instances but I am getting some issues while relocating SAP DVEBMGS00 instance from one node to another using SAPCTL utility. When I relocate DVEBGS00 from Node-B to Node-A, It moves along with its VIP to Node-A and tries to start there but then it fails to start sapstartsrv there and it moves back VIP and instance on Node-B.

I tried running DVEBMGS00 on Node-A by making CRS down on Node-B and Node-C and it is successfully running but when CRS is active on all 3 Nodes, DVEBMGS00 instance runs only on Node-B. It is not getting relocated to Node-A and Node-C.

One more issue: When DVEBMGS00 moves back to Node-B, it shuts down DB instance1 from Node-A and starts on Node-B. So Node-B gets two DB instance running from same Node. It is weird.

In my company's other systems SAP systems, by default ASCS,SCS and DVEBMGS00 instance run from Node-A.

Is it because of I run SAPInst from Node-B while installing DVEBMGS00 instance??

My Installation sequence was below.

ASCS01 installation on Node-A using virtual hostname (VIP was pointing to Node-A at the time of installation)

SCS02 installation on Node-A using Virtual Hostname (VIP was pointing to Node-A at the time of installation)

ERS03 for ASCS installation on Node-B using physical hostname

ERS04 for SCS installation on Node-B using physical hostname

DB Instance creation on Node-A

DVEBMGS00 installation using virtual hostname on Node-B (VIP was pointing to Node-B at the time of installation)

Installation was done on local disks so I manually replicated required files on another nodes. I tested SAP runs on all 3 nodes (I tested by bringing two cluster nodes down)

Could you please suggest me what could be the reason. Is there any installation sequence wrong? Only thing comes in my mind is I installed DVEBMGS00 on Node-B and I copied required files on Node-A and Node-C manually (that I do when I install HA system on Linux).

Thanks,

GS

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 14, 2015 at 08:33 AM

    It would be highly desirable to upload log files sapctl.log and logs releated to component which has been failed to start on affected node.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Roman,

      Sorry for updating very late on this but thought to update now for fellow members.

      Issue with sapstartsrv: Resolved by editing /usr/sap/sapservices file as there was some hidden character present.

      Issue with DB instance: DB instance 1 was getting relocated to Node B along with PAS service relocation from Node-A to Node-B: This was happening because one of the dbenv* profile at OS level of Node-B was updated with wrong instance number (DB instance number : one character SID1/SID2/SID3 etc.). Instead of SID2 it was SID1 due to that DB instance 1 was getting started on Node-B when PAS was moved to Node-B.

      Thanks,

      GS

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.