Skip to Content

Not able to activate the odata service

Hi,

I have SAP Hana studio installed in my machine and navigated to SAP HANA Development perspective. Created a local repository under 'Repositories' tab. Created a new project and mapped to the repository created in previous step. Now, I have access to odata services created by our team under a specific package. But I am not able to activate it.

Could any of you please help me know the reason why I am not able to activate it. I have all the privileges assigned to my username. I am not able to figure out why activate option is disabled for me for odata service.


Please have a look at the below screenshot.


Odata service.png (94.6 kB)
pastedImage_1.png (79.3 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    Posted on Dec 13, 2015 at 08:11 AM

    Hello,

    did you do any changes on the service definition? If you didn't do any changes the Activate option would be disabled.

    Regards, Florian

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 13, 2015 at 12:20 PM

    That is right. If you wanna copy your service definition you have to create a new xsodata service file, copy the content of the origin service and adjust the copied data to match the new file.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.