Skip to Content

Start and Stop Application Server

Hi All,

I created RFC destination of type T in SM59 of my ECC system but it connection test was not successful so I changed the gw/acl_mode = 0 in RZ10

After activating this profile I got pop up to restart my application server.

Can you please share the steps to restart the application server safely and all precautions need to be taken care here?

BR,

Rashmi

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Dec 11, 2015 at 01:27 PM

    Hello Rashmi,

    the parameter gw/acl_mode is a dynamic parameter.

    In transaction RZ11, you can change this parameter without a restart.

    Open transaction RZ11 --> insert gw/acl_mode and klick on Display --> klick on Change Value.

    After a restart from your system, the parameter has the value from your profile (RZ10). That means, you have to change the parameter also in RZ10.

    regards,

    Benedikt

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Rashmi,

      I don´t know that you want to do and what your error is. I think you will create a connection from a abap system to your PI, right?

      An RFC connection in transaction SM59 of type T needs a counterpart.

      Your counterpart can be a RFC sender communication channel (sender) in your PI or a JCO RFC Destination. You can create this type connection in the NWA from your PI.

      Mostly, a RFC sender channel is used in PI. The channel in PI and the connection in SM59 must have the same programm ID and the same Gateway-Host and Gateway-Service.

      It does not matter which gateway you will use. You can use the PI gateway (when the System is Dualstack) or the Gateway from your abap system.

      Please create the channel in PI as a counterpart for your abap system. Start the channel and check the connection test.

      When you have also no connection, I think you have a configuration problem. When you think the configuration is right, you can see in the log from your SAP gateway.

      The monitoring transaction for the abap gateway is SMGW.

      SMGW --> Goto --> Trace --> Gateway --> Display File

      To increase or reduce the log level goto

      SMGW --> Goto --> Trace --> Gateway --> Increase Level / Reduce Level

      There you can see the log from your gateway. But mostly, your gateway works fine and the problems is a wrong configuration from the RFC connection or your communication channel.

      The parameter gw/acl_mode is only a security parameter for the gateway.

      gw/acl_mode = 0 --> every connection is accepted

      gw/acl_mode = 1 --> only allowed connections are accpted.

      I hope this is helpful.

      regards,

      Benedikt

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.