Skip to Content
author's profile photo
Former Member

Workflow without approval not working

After upgade, our Workflow without approval for purchase orders is no long working. All lights are active for the appropriate Perform Task Specific Customering and for the Condition. In SWUD the workflow version 0001 is active and the version 0000 is "Revised/Saved". Before the upgrade this version was active.

Any suggestions?

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

9 Answers

  • author's profile photo
    Former Member
    Posted on Feb 16, 2006 at 02:27 PM

    That is the correct workflow we are using.

    The Purchase Order is in Awaiting Approval Status. When you click on the PO to enter Change mode we receive the following pop-up message "Document is still being processed in the background, Try again later"

    Also in /nswud after running a consistency check on the workflow WS14000075 we are seeing the following red errors:

    WS14000075 AppPO 0step Workflow Without Approval for Purch

    E WD:401 Workflow definition '' not in version ''

    I WD:060 The container element LastWorkitem is written, but not r

    I WD:060 The container element ExcludedAgents is written, but not

    I WD:060 The container element Initiator is written, but not read

    Please let me know if you need more information.

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 16, 2006 at 09:53 AM

    Hi Monaco,

    What is your new SRM release ?

    The mentioned WF is WS14000075 : correct ?

    Yann

    Message was edited by: Yann Bouillut

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Feb 16, 2006 at 11:52 AM

    Monaco,

    What do you mean by "not working":

    -The WF is not triggerd, and you get an error message in the PO creation/Modification

    -The WF is started, but no approver is found

    ??

    Regards.

    Vadim

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Feb 16, 2006 at 02:32 PM

    Release Information:

    SAP_ABA 640 0015 SAPKA64015

    SAP_BASIS 640 0015 SAPKB64015

    PI_BASIS 2005_1_640 0005 SAPKIPYJ65

    ST-PI 003C_640 0001 SAPKITLPS1

    SAP_BW 350 0014 SAPKW35014

    SRM_SERVER 500 0008 SAPKIBKS08

    SRM 4.0

    Add comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 16, 2006 at 03:03 PM

    Hi Monaco,

    Please check transaction SWETYPV.

    -> Select the line BUS2201, SAVED, WS1400075

    -> Hit the Details button

    -> In the 'Check Function Module' you should have 'SWB_CHECK_FB_START_COND_EVAL' (i am not sure as i do not have a system right now...)

    -> Save the changes

    Hope this helps,

    Yann

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Feb 16, 2006 at 06:14 PM

    I also should note that we are using Workflow without approval for shopping cart and that is working correctly.

    I went into the recommended trasaction code and the correct Function Module was listed.

    Receiver Call Function Module

    Receiver Function Module SWW_WI_CREATE_VIA_EVENT_IBF

    Check Function Module SWB_CHECK_FB_START_COND_EVAL

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Jul 03, 2006 at 12:42 AM

    Hi All,

    I'm facing the exact same issue as you guys.I have activated ws14000075(PO without approval) but for whatever reason the PO is still "awaiting approval".I checked SWDS it says workflow definition "not in version"

    I'm on SRM 5.0.I does appear lot of people have faced this issue.Could somebody please suggest what fixed this issue.I would really appreciate your help.

    Thanks and Regards,

    Rachel

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Jul 03, 2006 at 02:03 AM

    Im sorry i was not deatiled enough in describing the issue in my heading.I'm just reposting it.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Aug 21, 2007 at 05:29 AM

    Hi,

    Login to the Backend R/3 system.

    Release the PO in tcode /nME54n.

    Let me know if it works.

    Regards

    Bhagyashree

    Add comment
    10|10000 characters needed characters exceeded