Skip to Content
0
Dec 09, 2015 at 11:33 PM

Generic Data Source Error (R8147)

803 Views

This question has been asked before and answered, unfortunately the answers that show as correct from 2009 no longer work. Perhaps they did in whatever version was being used in 2009, but the same issue occurs now in 2015 and cannot be solved the same way. Here is the question and answer from 2009:

------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Hi, I am trying to create a Generic DataSource (Function Module) from a Structure that is copied from Table GLPCA. When I try to save the DataSource I get the following errors.

Units field WAERS for field HSL of DataSource ZBW_GLPCA is hidden (Message no. R8147)

Units field CURR2 for field KSL of DataSource ZBW_GLPCA is hidden (Message no. R8147)

An SDN and OSS Search doesn't provide any clues. Any ideas what I can do to get around this?

Former Member Correct Answer by Former Member on Sep 25, 2009 6:52 AM

Hi there,

If you are getting this error then

just add the fields WAERS and CURR2 in the extract structure itself which you are using for creating datasource.

Just give reference of same extract structure to those Amount fields for which references are WAERS and CURR2 in currency/ Quantity fields.

So reference table will be same as your extract structure and reference field will be WAERS or CURR2.

Hope this will help you.

Regards,

Rajdeep

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

If I attempt the solution above, I receive error messages stating that the "combination reference table/field xxxx-xxxx does not exist" and it is correct as the current version has not been saved and activated. I also tried to add the WAERS field first, then save and activate without errors and then go back into edit and add the references to my field, I still get the same error message.

I can use a standard table and WAERS such as P0008-WAERS and I can save and activate without issue, but when I go to RSO2 and create my generic datasource I get error messages on saving that state the field is hidden (the original posters error message). Before someone answers to just go to RSA6 and remove the Hide Field checkbox, I have tried this as well. Since my datasource does not save it is not available in RSA 6 to modify. I drilled into every datasource that contained the field WAERS and it is not hidden in any of them. This is becoming most frustrating, does anyone have an answer or solution?

Thanks,

Mike