Skip to Content
author's profile photo Former Member
Former Member

Problem Running Crystal Reports after Install (Visual C++ Runtime Error)

Tl;dr

I am trying to install Crystal Reports 13. I get this error when starting it. I can't find a useful channel for support.

I am attempting to install Crystal Reports 13 purchased through Digital River and received as a download link and serial key through email.

The install starts and checks all pre-reqs. Reports successful completion. However it gives me this error every time I try to start the program.


I have tried a few things already but I've noticed some of the sections of SAP's website is inaccessible to me without a login. My SAP account does not grant me access. Download lists, Incident Report section etc. I am assuming this is the correct method of getting support.

http://i.imgur.com/ltPgJ71.png

Event Log from Windows Logs > Application

Faulting application name: crw32.exe, version: 14.1.6.1702, time stamp: 0x556ceec7
Faulting module name: MSVCR80.dll, version: 8.0.50727.6195, time stamp: 0x4dcddbf3
Exception code: 0x40000015Fault offset: 0x000046b4
Faulting process id: 0x1120
Faulting application start time: 0x01d1329e06d74ac1
Faulting application path: C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\win32_x86\crw32.exe
Faulting module path: C:\Windows\WinSxS\x86_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.6195_none_d09154e044272b9a\MSVCR80.dll
Report Id: bdc707a2-9e91-11e5-81ac-c03fd5b4f10d

Solutions I have tried:

✓ Re-Installing Visual C++

✓ Installing Visual C++ 2008, 2010, 2012, 2013 to be available during installation

✓ Repairing Crystal Reports 2013 with Installer

✓ Re-Downloading Archive and installing from fresh archive from SAP Email

✓ Running Windows in Clean Startup Mode

✓ Re-Installing Visual C++

System Specs:

Windows 7 Professional 64-bit

Intel Core i5-4440 with 4GB of Memory

On a Workgroup

Using a local Administrator Account

Currently Installed Visual C++ Runtimes:

Microsoft Visual C++ 2005 Redistributable

Microsoft Visual C++ 2008 Redistributable- x 64 9.0.30729.6161

Microsoft Visual C++ 2010 x64 Redistributable 10.0.40219

Microsoft Visual C++ 2010 x86 Redistributable 10.0.40219

Microsoft Visual C++ 2012 Redistributable (x64) 11.061030

Microsoft Visual C++ 2013 Redistributable (x64) 12.0.30501

Microsoft Visual Studio 2010 Tools for Office Runtime (x64)

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Dec 09, 2015 at 05:13 PM

    What version of Windows are you running? Does your Crystal install indicate which service pack was installed? Did you install Crystal while logged in with Administrator rights to the computer where you're installing?

    -Dell

    Add a comment
    10|10000 characters needed characters exceeded

    • If you really want to find out I can send you the PDB's and you can use DebugDiag to find out what method/etc. is causing the loading of the dll. Possibly that would help, there are other tools out there for debug also...

      But, there are so many dependencies on CR products it's really tough to find tha actual cause. It could simply be one of your dll's is corrupted and only shows up in CR....

      At the end of the day though is it really worth the time to find the cause.... I too have spent countless hours trying to find "why" for other software and eventually had to FDISK...

      A good one was installing, when MS changed the c:\temp folder to \%user%\temp the program I was trying to install to did not like that I created my own temp folder... until I undid that change nothing would get the program to install. It threw an InstalllShield error... I finally realized I had changed the default behaviour of Windows 7, undoing that change fixed it...

      Don

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.