Skip to Content

Invalid SSL message, peer seems to be talking plain!

Hi experts,

I'm developing a receiver HTTPS client+user authentication on XI 7.0.

The interface is Proxy to SOAP.

Basis team have installed:

1) One HTTPS certificate, used for setting up a https connection to third party

.2) Another certificate, called Certificate to be trusted, used when accessing the https site and so setup the secure connection.

Because our basis are not skilled in XI, I need to know where to check if they have installed the 2 certificates correctly.

Also I need to know how to configure correctly my receiver CommChannel.

Now If I test the interface, it return the message Invalid SSL message, peer seems to be talking plain!

Thanks so much!!

Fabio

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Jan 07, 2016 at 09:04 AM

    Problem was HTTP protocol.

    Xi 7.0 manage only HTTP 1.0, third party only HTTP 1.1.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 09, 2015 at 04:42 PM

    Hi Fabio,

    I think you are using the port for http instead of the port for https.

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 10, 2015 at 02:01 AM

    Hi Fabio,

    There was a bug in PI wherein even if you state https:, the error will say "Peer seems to be talking plain". The solution was to place the default https port after the host e.g

    from https://google.com -> will not work with bug

    to https://google.com:443 -> will work

    Can you try it?

    Regards,

    Mark

    Add comment
    10|10000 characters needed characters exceeded