Skip to Content

Values missing in queue context. Target XSD requires a value for this element, but the target-field mapping does not create one. Check whether the XML instance is valid for the source XSD But delivered when Resent

Hi Experts,

if you see above question and want to say please check mapping.. Please read the following

1. This is happening in Production.. It retries the messages 3 times and fails. with above error.

2. The above error is mapping error. But, I took payload and tested in ESR, works fine,

3. Very surprisingly , When I resend the message it gets delivered.

Please help in finding what might be causing this issue..

Regards,

Vikas

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2015 at 10:25 AM

    Hello Vikas ,

    What is your receiver channel? Is it SOAP?

    Is your third party doing some check on the data when they receive the message?

    It might be possible that your third party is sometimes rejecting the data. Is it happening for all the messages or only few of them?

    You can also create one automatic restart job to increase the number of message restarts for this particular interface.

    http://scn.sap.com/community/pi-and-soa-middleware/blog/2013/05/05/create-your-own-automatic-message-restart-job-on-pi-java-stack-pi-73-ehp1

    Thanks.

    Add a comment
    10|10000 characters needed characters exceeded

    • Okay Gaurav,

      😊 no one should laugh at me for this, but it is an interface which is Proxy to IDoc (same ECC system receiver and sender) 😊

      Totally not my mistake as it was done in PI and I only migrated it to PO. i have raised this in rationalization points 😊

      Gonna mark your answer helpful as i suggested the same to client. but it is a time sensitive data and can't wait for so long for restart job to run.

      It is not happening it is happening sometimes and only for this particular interface.

      Regards,

      Vikas

  • author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2015 at 09:41 AM

    Hello Vikas,

    Have you tried refreshing cache ?

    Which version of PI you are using ?

    Regards,

    Mudassir

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.