Skip to Content

soap channel not capturing fault message

Hi Experts,

I am working on Proxy to soap scenario and working well and good until unless get the fault message.

The problem is I need to send 4 fields data to web services and 2 fields(keyword and page) are mandatory among those.

If I don’t send against keyword field I am able to get application error which is am anticipating here.

But there is another field “Page” if I don’t send to web services I am not getting application error instead I am able to system error.

Below is the screen shot

Note: I am not using Do not use soap envelop check mark

Also used this parameter XMBWS.NoSOAPIgnoreStatusCode in channel ..but no use.

Can anyone please tell me where is wrong.

12aaa.PNG (13.0 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Dec 04, 2015 at 12:58 PM

    Hi Maheswarareddy,

    The parameter XMBWS.NoSOAPIgnoreStatusCode doesn't work is you don't use "Do Not Use SOAP Envelope".

    You can try with the parameter:

    Module Key = soap

    Parameter Name = noSOAPMakeSysErrFromResponseFault

    Parameter Value = false

    Also you have the parameter suppressAppFault, if you don't want to catch the fault response.

    Regards.

    Message was edited by: Iñaki Vila

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.