Skip to Content

Issues with the maven command: mvn clean verify -U -Pfiori.eslint.bui ld

Hi All,

When ever I try to run the maven command to check for eslint errors :

mvn clean verify -U -Pfiori.eslint.build , I get the following error:

[ERROR] Failed to determine Java version for profile findbugs_jdk_6_and_7 @

com.sap.ldi:ldi-parent:7.2.0

[ERROR] Failed to determine Java version for profile findbugs_jdk_8_and_updw

ards @ com.sap.ldi:ldi-parent:7.2.0

[ERROR] Failed to determine Java version for profile findbugs_jdk_6_and_7 @

com.sap.ldi:ldi-parent:7.2.0

[ERROR] Failed to determine Java version for profile findbugs_jdk_8_and_updw

ards @ com.sap.ldi:ldi-parent:7.2.0

[ERROR] Failed to determine Java version for profile findbugs_jdk_6_and_7 @

com.sap.ldi:ldi-parent:7.2.0

[ERROR] Failed to determine Java version for profile findbugs_jdk_8_and_updw

ards @ com.sap.ldi:ldi-parent:7.2.0

[ERROR] Failed to determine Java version for profile findbugs_jdk_6_and_7 @

com.sap.ldi:ldi-parent:7.2.0

[ERROR] Failed to determine Java version for profile findbugs_jdk_8_and_updw

ards @ com.sap.ldi:ldi-parent:7.2.0

[ERROR] 'dependencies.dependency.version' is missing for com.sap.ui5:resourc

e:jar

[ERROR] 'dependencies.dependency.version' is missing for com.sap.ui5:core:ja

r:testresources

[ERROR] 'dependencies.dependency.version' is missing for com.sap.ushell:ushe

ll-lib:jar:testresources

[ERROR] 'dependencies.dependency.version' is missing for com.sap.ui5:table:j

ar

[ERROR] 'dependencies.dependency.version' is missing for com.sap.ca:ui:jar

[ERROR] 'dependencies.dependency.version' is missing for com.sap.ca:scfld.md

:jar

[ERROR]

[ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit

ch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.

[ERROR]

[ERROR] For more information about the errors and possible solutions, please rea

d the following articles:

[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildin

gException.

Can any one please help me know why do I get this error?

Regards,

Priya

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Dec 04, 2015 at 12:14 PM

    Hi Priya,

    Can you also provide the version of the jdk you have installed? And where?

    On the face of it, it appears that the jdk can't be found. Possibly maven is looking in one place and either the environmental variables are not set or the location is not the usual one. Not an expert, but ran into a similar problem a few years ago. Fixed that by setting the environmental variables so the program knew where the jdk was located.

    Regards, Mike

    SAP Technology RIG

    Message was edited by: Michael Appleby

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.