Skip to Content
avatar image
Former Member

SLES Enterprise vs SLES Enterprise for SAP?

Chaps,

We are installing SAP on HANA in a SLES environment on a TDI - i.e. we shall be building our own tin and installing SAP HANA rather than installing an appliance.  This will be running under VMWare, so all the HA will be handled there and we don't need the advanced HA functions of SLES for HANA.  As the subscription license costs are significantly different between SLES Enterprise and SLES Enterprise for SAP, we are wondering if there are any clear reasons why we need the SAP version.  Why can we not use standard SLES Enterprise?  None of the servers will be especially large - up to 256GB RAM in production.

Any advice/experiences would be welcome.

Thanks,

Graham

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Dec 01, 2015 at 11:08 AM

    Hi Graham,

    SAP standard recommendation on SUSE Linux is to use the SLES Enterprise for SAP and it does not change even if it is a TDI setup of HANA on VM or Hardware platform

    This is a tie up between SUSE and SAP to deliver a standard OS for all SAP Applications, SAP does allow any customization necessary for the Customers. It helps them troubleshoot issues better and eventually helps enhance the support in case of any specific issues on the OS

    The below articles should help clarify any questions on this topic(if you have not come across them already)

    Please check them and let us know if you have any further questions

    http://scn.sap.com/community/linux/blog/2015/06/26/what-makes-suse-linux-enterprise-server-sles-the-best-operating-environment-for-sap-infrastructures

    http://service.sap.com/sap/support/notes/1944799

    Hope this helps

    Sunil

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sunil,

      Thanks for the response.

      I have found some more information since raising this call that might prove helpful for others:

      SLES for SAP is built on SLES Enterprise with some add-ons.

      It includes kernel additions especially for memory management, as you would expect.

      There are some additional HA capabilities.

      In terms of patching, the agreement is that Linux patches may be up to 18 months behind, whereas Linux patching is normally required within 6 months of the patches being released - this may be an issue for systems that have very limited downtime.

      As we are using VMware for HA and do not have very availability requirements, we are going with standard SLES 12 Enterprise.

      Regards,

      Graham

  • avatar image
    Former Member
    Dec 08, 2015 at 11:52 AM

    Hi Graham,

    Even though u can use VMware HA capabilities, without SLES for SAP, I think you may face for support compliance issues from SAP for not using SAP recommended SLES version.

    Better to check that as well.

    Regards,

    Udara

    Add comment
    10|10000 characters needed characters exceeded