Skip to Content
author's profile photo Former Member
Former Member

Prevent double quotes around object names in output SQL?

Is there any way to stop DS 4.2 SP05 to put all column names, etc. in double quotes?

When testing DS against my MemSQL database, it keeps putting double quotes around all the object names, e.g.:

CREATE TABLE "testdb"."test_table" ( "Record_ID" INTEGER not null , primary key ("Record_ID"))


The above SQL fails.

However, if you take this SQL, remove the double quotes and execute it directly against MemSQL, it works fine.

So I want DS to generate the SQL like this:

CREATE TABLE testdb.test_table ( Record_ID INTEGER not null , primary key ( Record_ID))


Is there some option in DSCONFIG or anywhere else to get DS to behave the way I want it to?



Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Nov 27, 2015 at 08:14 AM

    Consider using UPPERCASE names for tables and columns only.

    Add a comment
    10|10000 characters needed characters exceeded

    • Yes, I didn't say DS would not put the double quotes. But normally an uppercase table or column name embedded in double quotes is totally equivalent to the same name without quotes.

      Is your database MySQL? I am not familiar with the specifics of that database type, but that may just mean it is currently not supporting ANSI_QUOTES. Check your database reference on how to change that mode.

  • Posted on Nov 27, 2015 at 09:15 AM

    Erik,

    I checked in DSConfig.txt and there doesnt seem to be any option for achieving this. The Double quotes are by default generated by the DS engine.

    Regards

    Arun Sasi

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 24, 2020 at 01:41 PM

    The answer and fixes are in SAP Note 2433146 for MySQL, but not sure if this applies also to MemSQL. The "Quote identifiers" option in the datastore configuration should allow you to send the sql to MySQL without quotes, but doesn't work. Fixes seem to apply to 14.2 SP's 7,8 and 9.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.