Skip to Content
avatar image
Former Member

Calculation data preview - No rows retrieved

Hi All,

I encountering a weird issue with a calculation view in HANA Studio and would need your guidance to resolve. I have created couple of attribute views and analytic views in HANA studio and do not have any issue. However, when I create  and activate a calculation view I am unable to preview the data. The issue here is that I do not see any activation error while activating or any privilege error when I am trying to display data.

These are the steps I followed:

1. Added the base table to the aggregation layer and added all the fields to output .

2. Marked one of the required fields as measure and activated.(No Analytic privileges were selected in the properties.)

3. Right click data preview I get the message no data to retrieve (Raw data tab).

4. Tried data preview by clicking instead of right click as well still no data to retrieve.

Few points to consider if it may help:

1. I can preview the data in the base table used in the calculation view without any issues.

2. I can preview the data if I use it in a attribute view or analytic view.

3. I can preview data of other calculation views created in other packages in the same system.

4. The calculation views where I cannot preview any data belong to a new package that I have created and I have no issues with attribute and analytic views in this package.

Could this be a security issue? If so what kind role should I be requesting for being able to preview the calculation view data in a new package.

Thank you,

Dexter

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Nov 21, 2015 at 06:52 AM

    Hi Dexter,

    Does you table have a client field in it??

    If then can you check what is the vlaue you have for  the default client  in view properties

    Select cross client option and actiavte the view.

    Regards

    Priyanka

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Priyanka,

      Thanks for your reply. The solution you provided worked perfectly. I never paid attention to that particular property at all.

      Regards,

      Dexter