Skip to Content

sapstart command not found unable to start Portal

Hi,

We are using EP 7.0 with database and instance are in different Hosts.

due to power failure both the AIX lpar servers down, we start both servers but while startsap command is executed its shows command not found.

i check the environment variable seems correct.

please help for the same.

EP.JPG (12.2 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Nov 17, 2015 at 11:02 AM

    Hi,

    Check if the PATH variable has kernel location mentioned in it.

    You can try to navigate to location /usr/sap/SID/SYS/exe/run and than execute startsap command.

    Regards,

    Prithviraj

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 17, 2015 at 02:52 PM

    Hi,

    in EP 7.0 i check the /usr/sap/SID/SYS/exe but find only symbolic link nor run folder is there.

    also i check the structure of EP 7.0 unicode java only all this are seems ok

    please confirm startsap file is in exe folder in java stack EP?

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello,

      Depending on which version was used at the original installation of this system (e.g., before any upgrades), the folder structure could vary.

      Just find which folder under the ".../SYS/exe" folder has the kernel files (like the "disp+work").

      It could be, for example, ".../SYS/exe/uc/linuxx86_64".

      The startsap script should be at that same folder.

  • Posted on Nov 17, 2015 at 04:01 PM

    Hello Isaias,

    Please find the attachment for the same only symbolic link are there. as per SAP System Directories on UNIX - SAP NetWeaver Library: Function-Oriented View - SAP Library

    check java unicode 7.0, no luck not able to execute the command

    Regards

    Naveen


    EP1.JPG (36.9 kB)
    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 19, 2015 at 05:46 AM

    Hi Manu,

    I check the /sapmnt/SID is mounted proper but in java ep in /sapmnt/SID/exe some sap related files are missing like startsap i manully copy the missing files and try to startsap.

    sap is started but new secure key certificate occur related, mention below.

    Error: Couldn't connect to DB

    com.sap.sql.log.OpenSQLException: Error while accessing secure store: The encryption key (usually in the key file) is not the

    key that is required to decrypt the data in the secure store file or the system name (SID) is wrong..

    i tried to regenerate the secure key but no luck and also follow the notes for the same.

    Regards

    Naveen

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 20, 2015 at 07:31 AM

    Hi,

    I Regenerate the secure key as per the note and copy to location but while startsap java.sql.SQLException: Io exception: The Network Adapter could not establish the connection is occur in jdbccon.log in same server db and instance are installed unable to find the solution.

    also

    [Thr 772] JHVM_RegisterNatives: registering methods in com.sap.bc.krn.perf.PerfT

    imes

    [Thr 772] JLaunchIExitJava: exit hook is called (rc = 66)

    [Thr 772] **********************************************************************

    *** ERROR => The Java VM terminated with a non-zero exit code.

    *** Please see SAP Note 943602 , section 'J2EE Engine exit codes'

    *** for additional information and trouble shooting.

    **********************************************************************

    [Thr 772] SigISetIgnoreAction : SIG_IGN for signal 20

    [Thr 772] JLaunchCloseProgram: good bye (exitcode = 66) in Bootstrap log.

    i followed all the threads but no luck.

    Regards

    Naveen

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.