Skip to Content
0

VA05: One Line per Item, not One Line per Schedule Line

Feb 03, 2017 at 02:29 PM

182

avatar image

2017-02-07-pastedimage.png

Hello!

I have an issue using VA05. The report shows multiple schedule lines for an item. I need to see one single line per item. Using variant 1SAP, I still see multiple lines per item.

Please advise.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Veselina Peykova
Feb 08, 2017 at 12:54 AM
1

If you wish to restore the original combination of fields for 1SAP - here are the fields and the sequence.


If you wish to have a single line per item in VA05 - just do not use in your layout fields, which get the information from the schedule line :)

You have schedule line quantity at the moment, of course you will get multiple lines per item... and goods issue date is from the schedule line, Order quantity is also from the schedule line, use Order Quantity instead.

There are probably more fields in your layout, which are causing problems for the same reason - just experiment a bit with a user-specific layout.


1sap.jpg (69.2 kB)
Show 3 Share
10 |10000 characters needed characters left characters exceeded

After playing with the layouts, we have been able to reduce some of the duplicated values that arise. Only when we keep the header fields, the line is not duplicating. Adding the 'Order Quantity' field duplicates these lines.

Duplicate item level items show up with the standard SAP layout. Please see attached screenshot for further insight. 2017-02-08-pastedimage.png

0

So... the problem is solved, right?

Some colleague of yours modified the standard layout 1SAP and added fields, which are at schedule line level. As a result, the modified layout started behaving like 3SAP, which caused your confusion.

Please close the question.

0

Your layout has an extra field labeled "Item". I don't even see it on our list of available fields, so can only guess it's a custom field.

Fields in the Veselina's screenshot worked for me.

0
G Lakshmipathi
Feb 03, 2017 at 03:14 PM
0

May be you have user role authorization issue. Check in SU01 > Parameter. There check SD_VARIANT_MAINTAIN with value "A" is set. If not, set this and retry.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

This did not work. The user authorisation matches what you have provided to me and the transaction still shows all tiems at a schedule line level, not an item level.

0

I already have that variant parameter set up and it does not seem to be the issue, i have copied the layout 01SAP (ITEMS) and i still see 2 lines per item when the item has 2 schedule lines2017-02-07-pastedimage.png

0
Jelena Perfiljeva
Feb 07, 2017 at 10:35 PM
0

VA05 is fundamentally a schedule line level report. I'm actually not sure how what you are looking for could be possibly achieved using a variant (which is just an ALV layout). You can't really use a filter for schedule line # because it could have anything in it. (Some people wrongly assume it'd always have line 1.) I guess you could sort and then subtotal by line item but that would add total lines.

I checked this variant in our system, it doesn't have any filters or totals and shows all schedule lines (unsurprisingly). Also it doesn't really seem to be protected, so anyone with authorization would be able to overwrite it.

I'd suggest to ask your SAP support team about this.

Share
10 |10000 characters needed characters left characters exceeded