Skip to Content
0
Former Member
Feb 13, 2006 at 10:32 PM

Version Compatability Problems with B1DE

13 Views

Hi all,

I have received confirmation from SAP support today that any add-on created in the UI-API must match the client version of the UI. In other words, I cannot design an add-on in 2004 and then deploy it with clients using version 2005.

That's all fine, I'll create two different versions of my add-ons. It's a pain for sure, but I can remove the references, add new ones and recompile. However, my problem arises when I need to use the B1DE to build my add-ons. The 2005 version of the B1DE won't (evidently) build add-on's for 2004. Therefore any time I want to compile the 2004 version of my add-on, I have to uninstall the 2005 version of the B1DE and install the 2004 version.

Does this sound right? I can't imagine it should be this difficult to create add-ons that will work with 2004 and 2005 at the same time.

Am I missing something here??!?