Skip to Content
avatar image
Former Member

import_own_cert Installation of certificate failed

Dear Expert,

We want to configure SSL for SAP Web Dispatcher and we have followed the following steps:

1.Create the Web Dispatcher Server PSE and generate a CSR

sapgenpse.exe get_pse -p C:\disp\sec\SAPSSLS.pse -r sapwebdisp.req " CN=fiori.dianaholding.ma, OU=SSLServer, O=SAP-AG, C=DE"

2. Signing the CA using COMMODO

the content of sapwebdisp.req is sent to COMMODO for signing

3. Import the CSR response into the server PSE using the following command :


sapgenpse import_own_cert -c sapwebdisp.cer -p C:\disp\sec\SAPSSLS.pse -x cert2015

when we excute this command the bellow error occurs : import_own_cert Installation of certificate failed

We have also tried to run the following command but it still gives the same error :

sapgenpse import_own_cert -c sapwebdisp.cer -p C:\disp\sec\SAPSSLS.pse -r AddTrustExternalCARoot.cer -x cert2015

Thanks in advance for your help,

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Nov 16, 2015 at 07:17 AM

    Hi Tarik,

    I would hope, that Commodo would deliver you no repsonse for this cert, as you requested it with O=SAP-AG. This is something only SAP is allowed to do. Please check the wiki on X.509 certificates for the meaning of O (Organization) and OU (organizational unit).

    If the problem still persists with a correct request, please post the complete error text, as the error can have more than one reason.

    Kind regards,

    Patrick

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Did you add the crt files to the PSE before trying the import?

      At least you did not specify all when trying to import the response, so this might already be the issue.

      Did you try the verbose switch ('-v' if I recall correctly)?