Skip to Content
author's profile photo Former Member
Former Member

E0073 EDI: Syntax error in IDoc (too many repetitions of a group)

Hi Experts,

We are getting this Idoc Error.

E0071 EDI: Syntax Error in IDoc (too many repetitions of a group).

It is for a Standard Segment / Standard Type -

Basic type: FIDCCP02

Segment: E1FISEC.

The allowed Maximum segments is 999. But there are 1194 segments in the Idoc.

As this is SAP Standard Type / Segment, we cannot change the Maximum number of Segments.

Please advise.

Thanks & Regards,

Sowmya

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Posted on Nov 13, 2015 at 01:40 PM

    Have a look at the following note and you need to go for modification as recommended in the note:-

    • Note 370021 - Maximum number of segments in ORDERS IDoc is too small

    G. Lakshmipathi

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Nov 13, 2015 at 10:41 AM

    FI Posting transaction and Idocs has got limitation 999 items. So we always have to think for an workaround to use them.

    Either split that document in multple Idocs and then let middleware ( If you are using ) club it or create an extension to the Idoc type and add your own segment and use that instead of the standard one.

    R

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Then go for a custom solution as I suggested.

      Create a extension. Add a custom sub segment under E1FISEC and same structure as E1FISEC and populate that via Exit/BADI. and use that custom segment while mapping.

      Or a non-recommended way is to apply access key and increase the max occurrence of the segment similar to the note suggested by G Lakshmipathi.

      R



  • Posted on Nov 13, 2015 at 11:23 AM

    Hi Sowmya,

    To prevent the IDOC error, one possible solution is to stop the E1FISEC segment from generating, if that segment is not necessary for you.

    You could filter out that segment using "Segment Filters" in BD56.

    ALE IDOC with Segment Filtering

    Thanks,

    Karthikeyan

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 19, 2015 at 06:00 AM

    Hi

    The maximum number of 999 is a standard setting and can not be changed without modification. You could try to limit the number of E1FISEC segments by sending only the segments that are required by the external party.

    An option is using a IDOC filter on this segment.

    Fields to filter can be defined in transaction BD95. Possible candidates are posting key (KSCHL),account type (KOART).

    Filter can be assigned to IDOC message type in transaction BD59.

    Filter values can be maintained in the ALE distribution model transaction BD64.

    Regards Jack

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.