Skip to Content
0
Former Member
Nov 12, 2015 at 05:04 PM

OII timeout issue

127 Views

Hi experts,

I need your help to identify the root cause for this sporadic failure in our BCM 6.0.11 / CRM 7 Ehp2 enviroment.

We´re using phone integration only.

Operator direct calls are handled via BCM CDT / Queue calls via CRM UI phone bar.

OII.Afterwork is set to 1

Normal procedure:

In CRM the agent clicks "Hang Up" to end a call and "End" to end the afterwork.

The status switches to "Ready" again.

Procedure in case of failure:

In CRM the agent clicks "Hang Up" but the UI keeps showing the connected call and keeps counting the time.

Clicking "End" has no effect.

The status is CDT works fine in both cases - the call ends and the status changes to "Afterwork".

The CRM webpage has to be refreshed to get it working again.

See both UIs with hanging CRM session in attached screenshot.

When the error occurs the OII log shows timeouts like this (all over 100000 ms):

09:24:35.620 EXC> phoneCallChanged failed in 100031 ms: appUrl=http://1.1.3.3:8025/sap(...)/bc/soap/ici?sap-session_access_token=...=appIds=[...]

callHandle: ...

lineNumber: +3xxxxx

processingStatus: 2/Active

callStatus: 101/Connected

capabilityList (13): 3 4 6 7 8 102 103 104 107 109 110 105 113

attachedData:

remoteNumbers (1): +3xxxxx

dialedNumber: +3xxxxx

inbound: False

internal: False

trunkId:

Timeout

System.Net.WebException: The operation has timed out

at System.Net.HttpWebRequest.GetRequestStream(TransportContext&context)

at System.Net.HttpWebRequest.GetRequestStream()

at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(StringmethodName, Object[] parameters)

at ICIEventClient.IciEventClient.phoneCallChanged(String[] appIds,iciPhoneCall phoneCall) in c:\bcm_sp11_source\bcm_6\source\source\ExtAppIntegration\WebServices\ChatLib\ICIEventClient.cs:line 140

at ChatLib.SubChanged.Notify(AsyncState state) in c:\bcm_sp11_source\bcm_6\source\source\ExtAppIntegration\WebServices\ChatLib\SubChanged

SAP already checked OII logs / ICI traces and suggested to check the network between both systems, but the network connection is fine.

On CRM side the collegues haven´t found any errors at all.

This is a normal OII status line:

11:14:15.305 TRC> (Status) State=Connected Chat=Disconnected Clients=235 Users=257 Items=33 Subs=296 [SOAP:0/5/5/25 q=0/1 ms=0/46/1375 #=7325] [Chat:0/0/0/25 q=0/0 ms=0/0/0]

This is a OII status after the error appeared (I´ve seen SOAP ms max. values above 200000ms):

16:24:13.289 TRC> (Status) State=Connected Chat=Disconnected Clients=181 Users=302 Items=38 Subs=256 [SOAP:0/5/6/25 q=0/1 ms=0/50/100140 #=32562] [Chat:0/0/0/25 q=0/0 ms=0/0/0]

Thanks in advance for your help.

Attachments