Skip to Content

Using a SP as main datasource and Universe for Sub Report

Hi there,

I currently have a report that uses a stored procedure to get the main data for a report, and it has a sub report that connects to a universe to display some other details. This all works fine in development on Crystal Reports for Enterprise. However when I move to our staging or production environments the report crashes when it loads as it is trying to access the Dev server.

I have done plenty of testing on this and the error only happens in the above scenario, for example just having a report that uses the universe as the datasource works fine as it does if I just use the SP with no sub report, in fact every scenario seems to work apart from where I have the main source linked to the SP with a sub report linked to the universe.

Has anyone seen anything similar or have any ideas of how to fix this?

Thanks

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Nov 10, 2015 at 01:29 PM

    I would first check the permissions granted the the user assigned to the report. It is very common for permissions to be different in the Development and a Production enviroments. If the user permissions are the same in both schemas then verify that the roles assigned are the same as well ( or are the appropriate roles depending on the configuration of the schema in both enviroments. if that doesn't work look for proper aliases or synomns again depending on the particular schemas used in your enviorment.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.