Skip to Content

The number range object does not exist for aggregate

Hi all,

I have a trouble with aggregates activation and filling.

In daily process chain we have program SAP_AGGREGATES_ACTIVATE_FILL for aggregate filling.

The filling of aggregates which belong to one particular cube fails everyday with error message "The number range object does not exist".

What is interesting when I manualy select "repeat" on the process chain step which failed, the aggregate is filled without any error.

I suspected that number range buffer could be an issue and therefore I increased number of numbers in buffer in SNRO (buffer set up to 500).

I've checked a table RSDDIMELOC and found all corresponding number ranges "BID*' for the problematic aggregates and increased the buffer.

But unfortunatelly it didn't help. It seems that number ranges for aggregates are generated at the moment when aggregate is filled.

It means that the setting I did yesterday for existing number ranges (from table RSDDIMELOC) is not valid today. Today I can see for the same aggregates new number ranges specified in this table.

We are on BW 7.0 version, Support package 31.

This problem started when we migrated from MSSQL database to ORACLE last week.

Any idea is very welcome.

Thank you.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    Posted on Nov 16, 2015 at 09:16 AM

    HI Guys,

    just a short feedback. Problem is caused by Oracle setting for parallel data processing.

    Workaround in BW can be setting in RSBATCHPARALLEL table.

    For aggregates I set up AGGRFILL with 1 parallel process.

    This setting solved my problem.

    We used to have 2 parallel proccesses set up in this table for aggregates.

    I don't see any decrease in performance after this setting.



    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 04, 2015 at 10:06 AM

    Hello Petr,

    Please review these knowledge base article and follow the solution part:

    1020812 - Number Range Interval Missing

    310751 - Number Ranges for Active Characteristics are Missing

    Hope it helps, br, Andras

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello Andras,

      thank you for your answer. Unfortunatelly it didn't correct my problem.

      I implemented everything from the 2 notes above but the aggregates filling and activation is still failing.

      I wanted to be sure that no number range is missing for any characteristic and therefore I run the RSD1 number range check for all characteristics. This step did not identify any issue.

      If you or someone else has idea how to solved this issue, it would be very appreciated.

      Thank you.

  • author's profile photo Former Member
    Former Member
    Posted on Nov 05, 2015 at 01:49 PM

    Hi Petr,

    Sorry my answer might be lame. Did you try RSRV?



    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.