Skip to Content

Maternity leave-unnecessary fields issue

Hello Gurus,

Seek your opinion on one issue that we face here.

We have different types of leave set up here, of which Maternity Leave is one. When the employee raises a maternity leave the leave screen that opens for her is as expected, with an option for attachment and limited fields:

However, when the manager gets the leave for approval, the screen displayed is altogether different:

Could any of you comment on why is it that the fields 'full day', company code' etc appear all of a sudden for the manager.

As you can see, the component and config seems to be the same yet the attachment is missing altogether and those unnecessary fields appear.

The rule group and process does not seem to be different for any leaves, yet this difference appears only for maternity leave.

Could you please guide on how to identify the cause for this occurrence? Since this is standard debugging, finding it difficult to track the exact cause.

Regards,

Vinay

Employee.jpg (33.6 kB)
Employee.jpg (43.6 kB)
Employee.jpg (77.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Nov 04, 2015 at 06:35 AM

    can u chk with another female employee user id and check with ur abaper of that wd screen attributes and in the screen i think it is standard only not Z screen ( customisation screen ) once chk with abaper or ur wd consultant

    Add comment
    10|10000 characters needed characters exceeded