Skip to Content
author's profile photo Former Member
Former Member

Problem with opening two online and offline stores in a single application using SP 10 for native iOS application?

Hi All,

When I'm trying to open two online and offline stores ,I'm able to run the application online but when i try to run the application in offline and call a web service it is giving me following error

"com.sap.smp.client.ios.odata.offline ERROR [-10028] Error at URL position 1: "Tracks" is not an entity set in entity container "MWORKLIST_2_SRV_Entities"

But it should call "AP_GW_SRV" entities .

Please help.

Thanks,

Praveen.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Nov 04, 2015 at 08:39 AM

    Hi Praveen,

    How many offline stores are there in your app?

    At a time you could open a maximum of 4 offline stores.

    Regards, Midhun

    SAP Technology RIG

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Midhun VP

      Hi Midhun,

      We don't have the access to the SMP Cockpit.

      We are calling two different base urls for opening two online and offline stores.

      @"MWORKLIST_2_SRV" and @"INVOICE_2_SRV"

      When im trying to call a webservice with base url @"INVOICE_2_SRV" with a collection name as @"Tracks".

      But it is hitting the base url @"MWORKLIST_2_SRV" and throwing an error.Please find the attached screen shot.


      NOTE: It is working fine in online but in offline we are not able to fetch .



      Please help.

      Thanks ,

      Praveen Kumar Addiki.

  • author's profile photo Former Member
    Former Member
    Posted on Nov 10, 2015 at 10:02 PM

    Praveen,

    I think this could be because you registered your mobile app against a Mobile Services application, and then changed the backend URL in the MS app. Your mobile app has kept the registration details in cache, including the first backend URL and that URL's entity container, which does not recognise the new entity set which is sent by your request, and cannot process it.

    You therefore need to refresh your registration details by unregistering your mobile application and registering again. Try clearing and closing your offline stores, too.

    Let me know if this helps.

    Christopher

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Nov 16, 2015 at 07:52 AM

    This message was moderated.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.