Skip to Content
avatar image
Former Member

Agentry Eclipse Plugin

Hi scn,

we are developing some modifications to standard Work Manager functionalities. We're using a development environment configured as per SAP help: http://help.sap.com/saphelp_smp307sdk/helpdata/en/7c/125dfc70061014b91491f47674add9/content.htm

Since we have some problems (eclipse sometimes dumps, modifications sometimes are not saved correctly, etc.), to install the latest Agentry Plugin version in Eclipse (without updating server side SDK) could be useful or dangerous?

From the final user point of view, for example, using the latest version of Agentry Client app is the best choice, even if it is not aligned with the SMP runtime version.

Do you have some hints?

Thank you so much,

Manuel

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Nov 03, 2015 at 09:14 PM

    Manuel,

    Generally speaking the SDK version will not match the SMP3 server version due to the release cycles and except for a few rare occasions there is not any dependency between them.  The latest SDK clients will work with any of the server versions but the older SDK clients may not always work with the latest SMP3 server version.

    In terms of the Editor I personally use the latest version of the plugin from a feature and stability standpoint and have not had any issues with the version of the Editor versus the server version.

    --Bill

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 03, 2015 at 08:00 PM

    Hi,

    You are getting confused, with too many variables.

    Firstly, issues with Eclipse has nothing to do with Agentry or SMP server side. Eclipse dumps and performance problems are based on your system RAM and space. Eclipse Juno is generally recommended with agentry plugin provided by SAP. We also had similar issues with eclipse and when we upgraded our systems to 16 gb RAM and i7 processecor, there are no such issues.

    Secondly, in SMP 3.0 server side is not dependent on SDK version. Unlike the previous versions of mobile platform, SMP 3.0 dose not need server runtime and SDK to be on same version. Eg: We use SMP 3.0 with sp 6.0 version where as our development SDK has sp 09 version.

    Hope this clarifies.

    Thanks,

    Shiv

    Add comment
    10|10000 characters needed characters exceeded