Skip to Content
A B

IDOC_AAE - Sender IDOC not found

Hello

We have installed new PO system and trying to test the idoc_aae. As per all blogs and sap notes, we have configured the default RFC and trfc ports in ECC as well.

I created a simple idoc_aae for invoices and used the ECC business system.

When i execute an idoc, i get an error at SM58 followed by log viewer in java stack found the following screenshot error.

I don't know what is causing this error. Even though the idoc sender channel is present, it says idoc sender is not there.

Regards

Sam

Capture.JPG (88.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

9 Answers

  • Nov 03, 2015 at 06:03 PM
    Add comment
    10|10000 characters needed characters exceeded

    • Hello

      Tried all forum links, but mine says can't find idoc sender communication channel in the log viewer which no one else seems to have this error.

      Regards

      Sam

  • avatar image
    Former Member
    Nov 04, 2015 at 12:50 PM

    Hi,

    you have to configure an IDOC sender channel for your business system and i think also a valid ico for the idoc you are doing your tests with, so that the idoc will not get stuck in sm58 on ecc side

    br

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 04, 2015 at 01:06 PM

    Hello

    I have already did that as well. I have created a simple business system with matching logical system of ECC.

    The only doubt is that the business system->related integration server will be referring another PI system as the sld is both shared across old and new PI system. But I guess if the ECC port defines the new PI system, that should be more than enough

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      so your SM59 destination (registered server program) works well?

      - Have you checked unicode settings

      - Check "Monitoring of idoc adapter" - Metadatamontior - you should see the fetched metadata

      br

  • Nov 04, 2015 at 01:35 PM

    Hi Raghu

    Yes, I can see the metadata as well and the sm59 works fine.It is just my idoc sender communication channel is not been found as per the log

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 04, 2015 at 01:43 PM

    Hi Raghu

    The one thing i noticed is that the idoc strucutre is not showing in the business system, when i double click it.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 04, 2015 at 02:46 PM

    Hello

    I had added using the following.

    SLD -> Technical Systems -> Select your Technical system -> Click Installed Software -> Select Add New Product -> here assign your product and software component.


    But still it has not reflected in my business system. I even cleared sld caches.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 04, 2015 at 03:11 PM

    Hi Raghu

    another thing i noticed is that the SWCV installed system doesn't show the PI technical system, it shows only the ECC technical systems.

    How do i fix it ?

    Regards

    Sam

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 04, 2015 at 03:54 PM

    Hi

    I have done that and saved and refreshed and even deleted and recreated the business system, But my SWCV and the related imported idocs are not been shown in the business system at all. 😔

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 04, 2015 at 04:17 PM

    Hello

    Now it is working fine when I create with a party and assign the business system as party identifier and execute the idoc.

    But it is still not working if I have idoc without party identifier and only with business system configured.

    Regards

    Sam

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      did you check the adapter specific identifiers on your business system in Integration Builder

      And just a question from my side: How did you do configuration for assigning the party to a business system

      br