Skip to Content

Industry Key Field in MDG-S Supplier UI

Hello Experts,

I am having one requirement to populate the industry key field BRSCH in MDG supplier UI under ERP vendor section,this field is not present in standard BP data model but present in GENIL model.

I have gone through the below post in which it mention as "branches have to be maintained as "Industries" on the business partner level. CVI takes care of mapping the default industry of the default industry system to the vendor's BRSCH field. Adding the field to BP_VENGEN is neither supported nor recommended."

BRSCH Industry Key issue in MDG-S | SCN

Not sure whether I need to enhance the BP_VENGEN entity with a custom attribute?

I have tried to follow that and gave industry system field under BP_INDSTR (Industry section UIBB) but still I am not getting the Industry key value in LFA1 under BRSCH field.

Could anyone please help of how can I make the industry key field populated in backend from UI.

Any useful pointers will be appreciated.



Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Nov 03, 2015 at 02:56 PM

    Hi Prateek,

    I would not use BP_VENGEN with an additional attribute. Because in that case industry is not populated on the BP and you get all kind of side effects. Which you can solve, but with a lot of effort.

    To check if the problem is between MDG and BP (UI / SMT mappings) or BP and Vendor (CVI) could you check if in your case the industry code is populated on the BP (check with transaction BP ).

    If the first case a lot could be wrong in the second case you should check the Industry code customizing. Which standard industry system is used. Use transaction SPRO and search for "Industry Systems".

    Next you need to maintain the mapping between the BP industry codes and Vendor industry codes.

    Use again transaction SPRO and search for "Settings for Vendor Integration" then go to Field assignement --> Assign Attributes --> Assign Industries. Define at least the outgoing mappping.



    Add comment
    10|10000 characters needed characters exceeded