Skip to Content

Result showing zero values

Hi,

In report selection we have sales org, period(e.g M (month)) and after written below customer exit code for zcreatdate to calculate last month 1st date to last date(e.g. 1/10/2015 to 31/10/2015).

WHEN 'zcreatdate'.  

   Data : l_val(2).

   DATA : I_SEL_OPT type standard table of RSDSSELOPT ,

          s_sel_opt type RSDSSELOPT .

     IF i_step = 2.

       LOOP AT i_t_var_range INTO loc_var_range WHERE vnam = 'ZRPRD'.

           l_val = loc_var_range-low.

         if l_val <> 'DR'.

         perform get_dates1 ( In this function calculate last month 1st date to last date(e.g. 1/10/2015 to 31/10/2015) and  it passes to s_sel_opt)

                           Tables I_SEL_OPT

                            using    l_val.

      read table I_SEL_OPT into  s_sel_opt index 1.

               l_s_range-low = s_sel_opt-low.

         l_s_range-high = s_sel_opt-high.

         l_s_range-sign = 'I'.

         l_s_range-opt = 'BT'.

         APPEND l_s_range to e_t_range.

         clear loc_var_range.

         endif.

      endloop.


But after executing query we getting zero values.


Here i have doubt for ZRPRD infoobject just maintained values manually like M(month),Y(Year), Q(Quarter), etc..


Because for user input for selection query to calculate dates based on periods(M,Q etc). For period we don't have data in info cube.


For this reason we not getting out put or any other?






Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 03, 2015 at 11:55 AM

    Hi Manjunatha

    What is the code written in perform get_dates1?


    Check if its using any FM or program to derive the first and last date of previous month. Lets say its using a FM, execute the FM manually with the data that you have in the infocube for ZRPRD.


    If the FM is not returning any result, then the issue is with your data.


    Please do this activity and let us know the outcome


    Regards

    Karthik



    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 03, 2015 at 11:58 AM

    Hi Manjunath,

    You can also try to run the query in debugging mode in RSRT.

    Before this set a breakpoint on the CMOD code.

    This will give you a fair idea of where the issue is.

    Regards,

    Amit

    Add comment
    10|10000 characters needed characters exceeded