Skip to Content

cannot start addon installation

Hello Everyone,

I'm trying to install new addon on SAP version 8.82 ,after registration when i go to addon manager, mark the addon and press Start i get the error message cannot start addon installation.

I tried several things from the server itself, like deletes temp files, open the client with run as administrator, rename files: AddOnsInstall.sbo and AddOnsLocalRegistration.sbo but nothing solve this issue.

How can I solve this?

Thank you

Eran

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Nov 02, 2015 at 10:51 PM

    Can you post a screenshot of the error message, and a copy/paste of the last few lines of your Status area in SAP? That might help.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 02, 2015 at 11:28 PM

    Hi Eran,

    As requested above can you give the logs, error, screenshot to understand and help you.

    Cheers

    Sharma

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 03, 2015 at 03:11 PM

    Hi Sharma and Westley,

    Thank you for your quick response.

    there isn't any log created or error message beside "cannot start addon installation."

    the steps i did was:

    1. go to addon administration > register new addon and press update.

    2. the system gets the update successfully.

    3. I'm changing the Default Group to manual.

    4. go to addon manager > mark the line and press Start.

    5. I'm getting the system message attached.

    another thing that might me important is that I succeed to install the addon both on the developer pc and on test environment but when trying to install on the customer server i get this system message.


    image.png (22.6 kB)
    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Eran Asayag

      Hi Eran,

      in this case check if you do not have the small .Net Framework installed at client site ...

      the UI/DI need the complete one as I remember...

      Regards

      Oliver

  • Nov 06, 2015 at 03:40 PM

    Hello to you all,

    I'm still can't install the addon, the last action we try was the re-install DI, update the .net framework, disable the DEP- data execution prevention,delete temp files and make sure again we are working with administrator with full permission on the server.

    still i'm getting the same error attached - cannot start addon installation.

    I also tried to install the addon from a workstation- their i gets a different error "cannot connect to DB"

    Thank you for your help

    Eran

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Eran,

      but it will install on other PCs??? right? So that your installation routine works on some other Workstations.?

      What you are using for your install routine? (ex. 14.AddOnInstaller from SDK??) In this routine you should open a window... and see the steps where your message is created...

      If you set the add-on Exe Files and Files needed in your Instalapp as Embedded Recourse and Copy Always it should work. If not... you have some issues on the local machine... If you done everything correct to the ARD file...

      And if you setup your compiler to x.86...

      Post some more information about how this is done... in the past I had nearly the same problem... and at least it was the property Copy Always from the embedded resource... Or the Permissions. and once it was f-secure that delete my exe file in a silent way... so I add a certification to my exe...

      If you write "Can not Connect to DB", that means the installation was success full???

      Regards

      Oliver

  • avatar image
    Former Member
    Nov 06, 2015 at 03:53 PM

    Have you verified that your connection strings are valid and work with another AddOn?

    Add comment
    10|10000 characters needed characters exceeded