Skip to Content
avatar image
Former Member

Error in phase MAIN_SHDIMP/SUBMOD_SHD2_RUN/RUN_RSGEN

Hi guys,

After new installation of Solution Manager 7.1 I am using SUM to install all components and solution packages required is step Check Software Prerequisites in System Preperation of SAP Solution Manager Configuration.

In SUM I was able to get to phase: 5.5: Preprocessing, but now I get error:

Severe error(s) occurred in phase MAIN_SHDIMP/SUBMOD_SHD2_RUN/RUN_RSGEN!

Last error code set: No entry with key '18575400/RSGEN_GENER8_SHADOW

Full log:

1 ETQ201 Entering upgrade-phase "MAIN_SHDIMP/SUBMOD_SHD2_RUN/RUN_RSGEN" ("20151102133011")

4 ETQ399 Set database connect to shadow.

4 ETQ399 Set environment for shadow connect:

4 ETQ399 Set RFC variables for shadow connect:

4 ETQ399 System-nr = '10', GwService = 'sapgw10' Client = '000'

4 ETQ380 computing toolpath for request "TP_SHADOW_CONNECT"

4 ETQ381 request "TP_SHADOW_CONNECT" means "tp needs to connect to shadow system"

4 ETQ382 translates to group "R3UP_TOOL_GROUP_NEW"

4 ETQ399 Requirement for tp maps to 'exe'

4 ETQ383 translates to path "C:\DownloadManager\SUM\abap\exe"

4 ETQ399 Set tool parameters for shadow connect with TPPARAM 'SHADOW.TPP'.

2 ETQ366 Connect variables are set for shadow instance access

4 ETQ399 System-nr = '10', GwService = 'sapgw10' Client = '000'

4 ETQ399 Environment variables:

4 ETQ399   dbs_ora_schema=SAPSR3

4 ETQ399   auth_shadow_upgrade=1

1 ETQ200 Executing actual phase 'MAIN_SHDIMP/SUBMOD_SHD2_RUN/RUN_RSGEN'.

1 ETQ399 Phase arguments:

2 ETQ399 Arg[0] = 'RSGEN_GENER8_SHADOW'

2 ETQ399 Arg[1] = 'SAP_SGEN'

2 ETQ399 Arg[2] = ''

2 ETQ399 Arg[3] = 'RSGEN\.$(SAPSID)'

2 ETQ399 Arg[4] = '10'

2 ETQ399 Arg[5] = 'Generate Program Loads'

1 ETQ399 Using error summary log 'RSGEN.ELG'.

1 ETQ399 Expanded phase arguments:

2 ETQ399 Arg[3] = 'RSGEN\.SM1'

1EETQ399 Last error code set is: No entry with key '18575400/RSGEN_GENER8_SHADOW'

1EETQ204 Upgrade phase "RUN_RSGEN" aborted with severe errors ("20151102133011")

In fact there was a problem with background job RSGEN_GENER8_SHADOW, but I have started it manually again and it finished correctly.

What I have already done:

1. Restarted SUM

2. Restarted shadow instance

3. Restarted main instance

4. I have tried to debug it but with no result.

Can You guys help me out somehow?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Nov 02, 2015 at 01:35 PM

    You should also have a look at the folowing SAP note :


    2061577 - SGEN errors out with 500+ errors in recent SAP_BASIS versions


    HTH,

    Best regards,

    Steve.


    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Steve Soumah

      I've tried to restart whole process but it crashed even earlier. SUM found inconsistency and that was it.

      I've already uninstalled Solman and I'm installing it again.

      Many thanks for Your help thou!

  • Nov 02, 2015 at 01:31 PM

    Hello,

    Could you upload the file RSGEN.ELG and also show the log of the RSGEN_GENER8_SHADOW batch job ?

    Thanks & BR,

    Steve.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Steve Soumah

      There is nothing in ST22.

      As for SM21 there are some errors, from last week.

      But now when I restart shadow instance everything is fine. No errors.

      Biggest problem is that my actions in SUM (repeating the  MAIN_SHDIMP/SUBMOD_SHD2_RUN/RUN_RSGEN! phase) are not represented in any way in SM21 or ST22.