Skip to Content
avatar image
Former Member

Java EE 6 WP / OSX / Eclipse - "Server failed to start"

Hi

Perhaps somebody can help. I have huge blocking issue with Eclipse / Java EE 6 WP on OSX El Capitan.

Basically server works fine one day, next morning doesn't want to start. Somehow I managed to restart it before by several reboots of the machine, but this is not the solution, I cannot work like this... So any suggestions?

There is nothing in the log file, the only thing that is visible is "Server failed to start" message in Eclipse w/o any details

Kind regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Nov 03, 2015 at 01:53 AM

    Hello Ivan,

    Do you receive any error message ? I guess you might see some information in the log.

    I had a similar issue and I simply killed the process via the terminal (mine was with Tomcat) using the following command: ps -ef | grep tomcat | awk '{print $2}' | xargs kill -9

    Cheers

    Greg

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Greg

      No error message except "Server failed to start.". Nothing in log file(s) either. Fairly frustrating.

      I thought perhaps there is a hanging process, but could not find one...

      😔

      I

  • avatar image
    Former Member
    Nov 03, 2015 at 07:56 AM

    Hi Ivan,

    Lets try and troubleshoot the problem, can you try a few things:

    0. Update the tools to the latest version.

    1. Try to ping localhost the resolved IP should be 127.0.x.1

    2. Open terminal go to the eclipse workspace/Servers/<your server> and try to launch the go.sh

    3. If there is still no obvious reason for the failure, in eclipse help choose "Collect Support Information". The wizard will create a zip file. You can send it to me as a mail attachment.

    Kind regards,

    Dimitar

    Add comment
    10|10000 characters needed characters exceeded