Skip to Content
avatar image
Former Member

WebIDE not pointing to Z gateway Service

Hello

I have created a  Z gateway service( on top of the standard sales order app service). Created a new extension of standard app in SAP WebIDE and called this new Z gateway service in "Component.js" file under "Service url variable".

Standard Service : SRA017_SALESORDER_CREATE_SRV

Z Gateway Service : ZTESTSRA017_SALESORDER_CREATE1_SRV

But when the sales order app is launched, i can see from chrome( F12) that the standard service is what is always called from the path

/sap/opu/odata/sap/SRA017_SALESORDER_CREATE_SRV/ and not the Z one.

IN SICF, this new Z service is also configured and ACTIVE and testing of this Z service works from backend, yet from the app always the standard service gets called? Why is this case?

Thanks

Abishek

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Nov 01, 2015 at 08:48 AM

    Hello

    Any help would be greatly appreciated.

    thanks

    Abishek

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 01, 2015 at 10:46 AM

    Can you share how you replace the service of component.js.

    It shold be like below;

      "sap.ca.serviceConfigs": [{
      "name": "SRA017_SALESORDER_CREATE_SRV",
      "serviceUrl": "/sap/opu/odata/sap/ZTESTSRA017_SALESORDER_CREATE1_SRV/",
      "isDefault": true,
      "mockedDataSource": "./localService/metadata.xml"
      }]
    
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 02, 2015 at 11:52 AM

    Hi Adem

    It is exactly like you pointed out.

    It was working fine a month ago. There has some updates in the backend system and after that it is not working. But the irony is when I test this Z service from backend it works perfectly fine.

    It is only when i use the APP, the service called is the standard one and not the Z one.

    Thanks

    Abishek


    image.JPG (27.9 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Nov 02, 2015 at 11:59 AM

    The  post url that is called is

    I have another query, am using a trial version of SAP HCP. I configured WEBIDE in this. Is there any special settings that needs to be done for calling Z gateway services from HCP?

    Thanks

    Abishekk


    POSTUrl.JPG (20.1 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Nov 02, 2015 at 01:45 PM

    Hi Abishek,

    Please have a look to below post.

    SAPUI5 – Cloud Connector

    Is there any changes in Virtual Host URL ?

    Thanks-

    Abhishek

    Add comment
    10|10000 characters needed characters exceeded